summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2012-10-27 22:27:55 +1300
committerRobert Collins <robertc@robertcollins.net>2012-10-27 22:27:55 +1300
commitf8e93227207a1eddef02cb306651074172f64188 (patch)
tree1130670ee05bf24efccc0ce81f8bba6bb8fb5052 /setup.py
parent87a05a447f982e4ddc954fb2c72fa59637c4bd58 (diff)
downloadpython-test-extras-f8e93227207a1eddef02cb306651074172f64188.tar.gz
Initial extraction of code from testtools.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..fb7b0c3
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/env python
+"""Distutils installer for extras."""
+
+from distutils.core import setup
+import os.path
+
+import extras
+
+
+def get_version():
+ """Return the version of extras that we are building."""
+ version = '.'.join(
+ str(component) for component in extras.__version__[0:3])
+ return version
+
+
+def get_long_description():
+ readme_path = os.path.join(
+ os.path.dirname(__file__), 'README.rst')
+ return open(manual_path).read()
+
+
+setup(name='extras',
+ author='Testing cabal',
+ author_email='testtools-dev@lists.launchpad.net',
+ url='https://github.com/testing-cabal/extras',
+ description=('Useful extra bits for Python - things that shold be '
+ 'in the standard library'),
+ long_description=get_long_description(),
+ version=get_version(),
+ classifiers=["License :: OSI Approved :: MIT License"],
+ packages=[
+ 'extras',
+ 'extras.tests',
+ ],
+ cmdclass={'test': testtools.TestCommand})