summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile32
1 files changed, 3 insertions, 29 deletions
diff --git a/Makefile b/Makefile
index 9d5b515..270e8d1 100644
--- a/Makefile
+++ b/Makefile
@@ -12,21 +12,10 @@ TAGS: ${SOURCES}
tags: ${SOURCES}
ctags -R extras/
-clean: clean-sphinx
+clean:
rm -f TAGS tags
find extras -name "*.pyc" -exec rm '{}' \;
-prerelease:
- # An existing MANIFEST breaks distutils sometimes. Avoid that.
- -rm MANIFEST
-
-release:
- ./setup.py sdist upload --sign
- $(PYTHON) scripts/_lp_release.py
-
-snapshot: prerelease
- ./setup.py sdist
-
### Documentation ###
apidocs:
@@ -36,21 +25,6 @@ apidocs:
--docformat=restructuredtext --project-name=extras \
--project-url=https://launchpad.net/extras
-doc/news.rst:
- ln -s ../NEWS doc/news.rst
-
-docs: doc/news.rst docs-sphinx
- rm doc/news.rst
-
-docs-sphinx: html-sphinx
-
-# Clean out generated documentation
-clean-sphinx:
- cd doc && make clean
-
-# Build the html docs using Sphinx.
-html-sphinx:
- cd doc && make html
-.PHONY: apidocs docs-sphinx clean-sphinx html-sphinx docs
-.PHONY: check clean prerelease release
+.PHONY: apidocs
+.PHONY: check clean