summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen D. Huston <shuston@apache.org>2009-01-07 22:25:21 +0000
committerStephen D. Huston <shuston@apache.org>2009-01-07 22:25:21 +0000
commit2675b08dcbf51fe2e1806590173087f685690ea6 (patch)
tree69188dcdd519b65380ed9a64594519986da0b201
parentaeee123a1400999290f8dc262c415a710e4d6204 (diff)
downloadqpid-python-2675b08dcbf51fe2e1806590173087f685690ea6.tar.gz
Added cluster-related gen file to protocol_gen.mak and regenerated all VC projects; left out qmfconsole since it won't build
git-svn-id: https://svn.apache.org/repos/asf/qpid/branches/M4-RCs@732540 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/MaxMethodBodySize.vcproj2
-rw-r--r--qpid/cpp/src/broker.vcproj2
-rw-r--r--qpid/cpp/src/client.vcproj2
-rw-r--r--qpid/cpp/src/common.vcproj134
-rw-r--r--qpid/cpp/src/protocol_gen.mak10
-rw-r--r--qpid/cpp/src/qpid.sln91
6 files changed, 179 insertions, 62 deletions
diff --git a/qpid/cpp/src/MaxMethodBodySize.vcproj b/qpid/cpp/src/MaxMethodBodySize.vcproj
index cce8b0a8e1..1b1cf67433 100644
--- a/qpid/cpp/src/MaxMethodBodySize.vcproj
+++ b/qpid/cpp/src/MaxMethodBodySize.vcproj
@@ -24,7 +24,7 @@
ProjectType="Visual C++"
Version="9.00"
Name="MaxMethodBodySize"
- ProjectGUID="{CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}"
+ ProjectGUID="{CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}"
RootNamespace="MaxMethodBodySize"
Keyword="Win32Proj"
SignManifests="true"
diff --git a/qpid/cpp/src/broker.vcproj b/qpid/cpp/src/broker.vcproj
index 63174dad73..aaa7c0ce54 100644
--- a/qpid/cpp/src/broker.vcproj
+++ b/qpid/cpp/src/broker.vcproj
@@ -24,7 +24,7 @@
ProjectType="Visual C++"
Version="9.00"
Name="broker"
- ProjectGUID="{09613D48-FECA-1BAD-9D20-8C374564ADCF}"
+ ProjectGUID="{09613D48-FECA-1BAD-9D20-8C37688E2823}"
RootNamespace="broker"
Keyword="Win32Proj"
SignManifests="true"
diff --git a/qpid/cpp/src/client.vcproj b/qpid/cpp/src/client.vcproj
index f7fbffeff1..a2d02e9ffc 100644
--- a/qpid/cpp/src/client.vcproj
+++ b/qpid/cpp/src/client.vcproj
@@ -24,7 +24,7 @@
ProjectType="Visual C++"
Version="9.00"
Name="client"
- ProjectGUID="{6961DBA3-FECA-1BAD-F396-8C394564ADCF}"
+ ProjectGUID="{6961DBA3-FECA-1BAD-F396-8C39688E2823}"
RootNamespace="client"
Keyword="Win32Proj"
SignManifests="true"
diff --git a/qpid/cpp/src/common.vcproj b/qpid/cpp/src/common.vcproj
index 253bdcba58..39429078f3 100644
--- a/qpid/cpp/src/common.vcproj
+++ b/qpid/cpp/src/common.vcproj
@@ -24,7 +24,7 @@
ProjectType="Visual C++"
Version="9.00"
Name="common"
- ProjectGUID="{C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}"
+ ProjectGUID="{C961EF23-FECA-1BAD-BB9C-8C3A688E2823}"
RootNamespace="common"
Keyword="Win32Proj"
SignManifests="true"
@@ -360,6 +360,72 @@
RelativePath="gen\qpid\framing\ClientInvoker.cpp">
</File>
<File
+ RelativePath="gen\qpid\framing\ClusterConfigChangeBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionAccumulatedAckBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionConsumerStateBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionDeliverCloseBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionDeliverDoOutputBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionDeliveryRecordBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionExchangeBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionMembershipBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionQueueBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionQueuePositionBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionSessionStateBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionShadowReadyBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxAcceptBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxDequeueBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxEndBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxEnqueueBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxPublishBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxStartBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterDumpOfferBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterDumpRequestBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterReadyBody.cpp">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterShutdownBody.cpp">
+ </File>
+ <File
RelativePath="gen\qpid\framing\ConnectionCloseBody.cpp">
</File>
<File
@@ -1000,6 +1066,72 @@
RelativePath="gen\qpid\framing\ClientInvoker.h">
</File>
<File
+ RelativePath="gen\qpid\framing\ClusterConfigChangeBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionAccumulatedAckBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionConsumerStateBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionDeliverCloseBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionDeliverDoOutputBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionDeliveryRecordBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionExchangeBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionMembershipBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionQueueBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionQueuePositionBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionSessionStateBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionShadowReadyBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxAcceptBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxDequeueBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxEndBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxEnqueueBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxPublishBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterConnectionTxStartBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterDumpOfferBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterDumpRequestBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterReadyBody.h">
+ </File>
+ <File
+ RelativePath="gen\qpid\framing\ClusterShutdownBody.h">
+ </File>
+ <File
RelativePath="gen\qpid\framing\ConnectionCloseBody.h">
</File>
<File
diff --git a/qpid/cpp/src/protocol_gen.mak b/qpid/cpp/src/protocol_gen.mak
index 2680bf220e..5c61eb90d5 100644
--- a/qpid/cpp/src/protocol_gen.mak
+++ b/qpid/cpp/src/protocol_gen.mak
@@ -7,16 +7,14 @@
# repository.
specdir = ..\..\specs
-# To add cluster support, add ..\xml\cluster.xml to specs, then add sources
-# to project files.
-specs = $(specdir)\amqp.0-10-qpid-errata.xml
+specs = $(specdir)\amqp.0-10-qpid-errata.xml ..\xml\cluster.xml
rgen_dir=..\rubygen
mgen_dir=..\managementgen
-mgmt_specs=$(specdir)\management-schema.xml .\qpid\acl\management-schema.xml
-# To add cluser management, add the next line to mgen_specs:
-# .\qpid\cluster\management-schema.xml
+mgmt_specs=$(specdir)\management-schema.xml \
+ .\qpid\acl\management-schema.xml \
+ .\qpid\cluster\management-schema.xml
all: rubygen.mk gen\generate_MaxMethodBodySize_h.cpp managementgen.mk
diff --git a/qpid/cpp/src/qpid.sln b/qpid/cpp/src/qpid.sln
index 7ace10735d..8e886cf7a4 100644
--- a/qpid/cpp/src/qpid.sln
+++ b/qpid/cpp/src/qpid.sln
@@ -8,26 +8,21 @@ Microsoft Visual Studio Solution File, Format Version 10.00
#
# MPC Command:
# C:\ace\MPC\mwc.pl -type vc9 -features boost=1 -static qpid.mwc
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "MaxMethodBodySize", "MaxMethodBodySize.vcproj", "{CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}"
+Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "MaxMethodBodySize", "MaxMethodBodySize.vcproj", "{CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}"
EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "broker", "broker.vcproj", "{09613D48-FECA-1BAD-9D20-8C374564ADCF}"
+Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "broker", "broker.vcproj", "{09613D48-FECA-1BAD-9D20-8C37688E2823}"
ProjectSection(ProjectDependencies) = postProject
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF} = {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823} = {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}
EndProjectSection
EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "client", "client.vcproj", "{6961DBA3-FECA-1BAD-F396-8C394564ADCF}"
+Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "client", "client.vcproj", "{6961DBA3-FECA-1BAD-F396-8C39688E2823}"
ProjectSection(ProjectDependencies) = postProject
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF} = {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823} = {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}
EndProjectSection
EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "common", "common.vcproj", "{C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}"
+Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "common", "common.vcproj", "{C961EF23-FECA-1BAD-BB9C-8C3A688E2823}"
ProjectSection(ProjectDependencies) = postProject
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF} = {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}
- EndProjectSection
-EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "qmfconsole", "qmfconsole.vcproj", "{C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}"
- ProjectSection(ProjectDependencies) = postProject
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF} = {6961DBA3-FECA-1BAD-F396-8C394564ADCF}
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823} = {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}
EndProjectSection
EndProject
Global
@@ -38,46 +33,38 @@ Global
Release|x64 = Release|x64
EndGlobalSection
GlobalSection(ProjectConfigurationPlatforms) = postSolution
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|Win32.ActiveCfg = Debug|Win32
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|Win32.Build.0 = Debug|Win32
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|x64.ActiveCfg = Debug|x64
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|x64.Build.0 = Debug|x64
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|Win32.ActiveCfg = Release|Win32
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|Win32.Build.0 = Release|Win32
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|x64.ActiveCfg = Release|x64
- {CB5C939B-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|x64.Build.0 = Release|x64
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Debug|Win32.ActiveCfg = Debug|Win32
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Debug|Win32.Build.0 = Debug|Win32
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Debug|x64.ActiveCfg = Debug|x64
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Debug|x64.Build.0 = Debug|x64
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Release|Win32.ActiveCfg = Release|Win32
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Release|Win32.Build.0 = Release|Win32
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Release|x64.ActiveCfg = Release|x64
- {09613D48-FECA-1BAD-9D20-8C374564ADCF}.Release|x64.Build.0 = Release|x64
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Debug|Win32.ActiveCfg = Debug|Win32
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Debug|Win32.Build.0 = Debug|Win32
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Debug|x64.ActiveCfg = Debug|x64
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Debug|x64.Build.0 = Debug|x64
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Release|Win32.ActiveCfg = Release|Win32
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Release|Win32.Build.0 = Release|Win32
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Release|x64.ActiveCfg = Release|x64
- {6961DBA3-FECA-1BAD-F396-8C394564ADCF}.Release|x64.Build.0 = Release|x64
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|Win32.ActiveCfg = Debug|Win32
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|Win32.Build.0 = Debug|Win32
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|x64.ActiveCfg = Debug|x64
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Debug|x64.Build.0 = Debug|x64
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|Win32.ActiveCfg = Release|Win32
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|Win32.Build.0 = Release|Win32
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|x64.ActiveCfg = Release|x64
- {C961EF23-FECA-1BAD-BB9C-8C3A4564ADCF}.Release|x64.Build.0 = Release|x64
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Debug|Win32.ActiveCfg = Debug|Win32
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Debug|Win32.Build.0 = Debug|Win32
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Debug|x64.ActiveCfg = Debug|x64
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Debug|x64.Build.0 = Debug|x64
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Release|Win32.ActiveCfg = Release|Win32
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Release|Win32.Build.0 = Release|Win32
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Release|x64.ActiveCfg = Release|x64
- {C95DE177-FECA-1BAD-5EDC-8FFA4564ADCF}.Release|x64.Build.0 = Release|x64
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Debug|Win32.ActiveCfg = Debug|Win32
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Debug|Win32.Build.0 = Debug|Win32
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Debug|x64.ActiveCfg = Debug|x64
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Debug|x64.Build.0 = Debug|x64
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Release|Win32.ActiveCfg = Release|Win32
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Release|Win32.Build.0 = Release|Win32
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Release|x64.ActiveCfg = Release|x64
+ {CB5C939B-FECA-1BAD-BB9C-8C3A688E2823}.Release|x64.Build.0 = Release|x64
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Debug|Win32.ActiveCfg = Debug|Win32
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Debug|Win32.Build.0 = Debug|Win32
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Debug|x64.ActiveCfg = Debug|x64
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Debug|x64.Build.0 = Debug|x64
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Release|Win32.ActiveCfg = Release|Win32
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Release|Win32.Build.0 = Release|Win32
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Release|x64.ActiveCfg = Release|x64
+ {09613D48-FECA-1BAD-9D20-8C37688E2823}.Release|x64.Build.0 = Release|x64
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Debug|Win32.ActiveCfg = Debug|Win32
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Debug|Win32.Build.0 = Debug|Win32
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Debug|x64.ActiveCfg = Debug|x64
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Debug|x64.Build.0 = Debug|x64
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Release|Win32.ActiveCfg = Release|Win32
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Release|Win32.Build.0 = Release|Win32
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Release|x64.ActiveCfg = Release|x64
+ {6961DBA3-FECA-1BAD-F396-8C39688E2823}.Release|x64.Build.0 = Release|x64
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Debug|Win32.ActiveCfg = Debug|Win32
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Debug|Win32.Build.0 = Debug|Win32
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Debug|x64.ActiveCfg = Debug|x64
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Debug|x64.Build.0 = Debug|x64
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Release|Win32.ActiveCfg = Release|Win32
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Release|Win32.Build.0 = Release|Win32
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Release|x64.ActiveCfg = Release|x64
+ {C961EF23-FECA-1BAD-BB9C-8C3A688E2823}.Release|x64.Build.0 = Release|x64
EndGlobalSection
GlobalSection(SolutionProperties) = preSolution
HideSolutionNode = FALSE