summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-04-23 22:13:14 +0000
committerAlan Conway <aconway@apache.org>2008-04-23 22:13:14 +0000
commit46d3a97ee717a63c7c688792520d01b04c7848c3 (patch)
tree66a8a3b993d74eee16f98a2b0c4e41ad4d44126a
parent14160c1b30cbfb5d739c1fff58f69fba892626b1 (diff)
downloadqpid-python-46d3a97ee717a63c7c688792520d01b04c7848c3.tar.gz
Fix build error introduced by earlier commit.
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@651088 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/src/tests/Makefile.am2
-rw-r--r--qpid/cpp/src/tests/unit_test.h8
2 files changed, 2 insertions, 8 deletions
diff --git a/qpid/cpp/src/tests/Makefile.am b/qpid/cpp/src/tests/Makefile.am
index c5baf5c73b..bd020e4f77 100644
--- a/qpid/cpp/src/tests/Makefile.am
+++ b/qpid/cpp/src/tests/Makefile.am
@@ -1,4 +1,4 @@
-AM_CXXFLAG = $(WARNING_CFLAGS) $(CPPUNIT_CXXFLAGS) $(APR_CXXFLAGS) -DBOOST_TEST_DYN_LINK
+AM_CXXFLAGS = $(WARNING_CFLAGS) $(CPPUNIT_CXXFLAGS) $(APR_CXXFLAGS) -DBOOST_TEST_DYN_LINK
INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../gen -I$(top_builddir)/src/gen
abs_builddir=@abs_builddir@
diff --git a/qpid/cpp/src/tests/unit_test.h b/qpid/cpp/src/tests/unit_test.h
index e757961616..b986c74afa 100644
--- a/qpid/cpp/src/tests/unit_test.h
+++ b/qpid/cpp/src/tests/unit_test.h
@@ -45,18 +45,12 @@
# define QPID_AUTO_TEST_SUITE_END()
#elif (BOOST_VERSION < 103400)
-
+// Note the trailing ';'
# define QPID_AUTO_TEST_SUITE(name) BOOST_AUTO_TEST_SUITE(name);
# define QPID_AUTO_TEST_SUITE_END() BOOST_AUTO_TEST_SUITE_END();
-#elif (BOOST_VERSION < 103400)
-
-# define QPID_AUTO_TEST_SUITE(name) BOOST_AUTO_TEST_SUITE(name)
-# define QPID_AUTO_TEST_SUITE_END() BOOST_AUTO_TEST_SUITE_END()
-
#endif // Workarounds for BOOST_AUTO_TEST_CASE|SUITE|SUITE_END
-
// Workaround for BOOST_AUTO_TEST_SUITE_EXPECTED_FAILURES
//
#if (BOOST_VERSION < 103500)