summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-06-23 13:53:15 +0000
committerAlan Conway <aconway@apache.org>2008-06-23 13:53:15 +0000
commit71215099a30812c8a3b8f39e206babe31b7e79ab (patch)
tree9ce86f70b8f76683df27a54b400284ae38b30ccd
parent7c28f2de84d72c843f9aa113aa0e1e8ce3aef4d5 (diff)
downloadqpid-python-71215099a30812c8a3b8f39e206babe31b7e79ab.tar.gz
Fix path problems in examples make check
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@670571 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--qpid/cpp/examples/Makefile5
-rw-r--r--qpid/cpp/examples/Makefile.am5
-rwxr-xr-xqpid/cpp/examples/verify_all2
3 files changed, 9 insertions, 3 deletions
diff --git a/qpid/cpp/examples/Makefile b/qpid/cpp/examples/Makefile
index 47c01351a9..82418a7596 100644
--- a/qpid/cpp/examples/Makefile
+++ b/qpid/cpp/examples/Makefile
@@ -202,6 +202,9 @@ SUBMAKE = ' for d in $(SUBDIRS) ; do $$(MAKE) -C $$$$d $$@ ; done'
examplesdir = $(pkgdatadir)/examples
examples_DATA = README $(MAKEDIST)
EXTRA_DIST = $(examples_DATA) README.verify verify verify_all
+
+# For older versions of automake
+abs_top_srcdir = /home/aconway/qpid/cpp/examples/..
all: all-recursive
.SUFFIXES:
@@ -542,7 +545,7 @@ $(MAKEDIST): Makefile
# Verify the examples in the buid tree.
check-local:
- $(srcdir)/verify_all $(abs_top_srcdir)/.. $(abs_top_builddir)/src/qpidd $(exclude_examples_regexp)
+ $(srcdir)/verify_all $(abs_top_srcdir)/.. $(top_builddir)/src/qpidd $(exclude_examples_regexp)
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
diff --git a/qpid/cpp/examples/Makefile.am b/qpid/cpp/examples/Makefile.am
index 6c3cc4c745..8de2137178 100644
--- a/qpid/cpp/examples/Makefile.am
+++ b/qpid/cpp/examples/Makefile.am
@@ -17,7 +17,10 @@ examples_DATA = README $(MAKEDIST)
EXTRA_DIST = $(examples_DATA) README.verify verify verify_all
+# For older versions of automake
+abs_top_srcdir = @abs_top_srcdir@
+
# Verify the examples in the buid tree.
check-local:
- $(srcdir)/verify_all $(abs_top_srcdir)/.. $(abs_top_builddir)/src/qpidd $(exclude_examples_regexp)
+ $(srcdir)/verify_all $(abs_top_srcdir)/.. $(top_builddir)/src/qpidd $(exclude_examples_regexp)
diff --git a/qpid/cpp/examples/verify_all b/qpid/cpp/examples/verify_all
index 9fbaa4a8df..3bb259e096 100755
--- a/qpid/cpp/examples/verify_all
+++ b/qpid/cpp/examples/verify_all
@@ -15,7 +15,7 @@ PYTHONPATH=$python:$PYTHONPATH
export QPID_PORT PYTHON_EXAMPLES PYTHONPATH
test -d $PYTHON_EXAMPLES || echo "WARNING: No python examples. $PYTHON_EXAMPLES not found."
-find="find examples"
+find="find"
test -d $PYTHON_EXAMPLES && find="$find $PYTHON_EXAMPLES"
find="$find -name verify"
test -d $PYTHON_EXAMPLES && \