summaryrefslogtreecommitdiff
path: root/qpid/cpp/bootstrap
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-06-07 14:29:24 +0000
committerAlan Conway <aconway@apache.org>2007-06-07 14:29:24 +0000
commit2bc2c756906232e5182cdf0de96840661688297b (patch)
treed8c2d4d2464714c442fd70d9780a8eb967a39403 /qpid/cpp/bootstrap
parent3a00442a29d77282fe3fb4a810627deae319c796 (diff)
downloadqpid-python-2bc2c756906232e5182cdf0de96840661688297b.tar.gz
Build support for clustering, initial CPG wrapper & tests.
- src/qpid/cluster/Cpg.cpp: C++ wrapper for the openais CPG library. - src/tests/unit/Cpg.cpp: verify CPG functions in make check. - makefiles etc.: build cluster stuff only if openais is installed. git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@545190 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/bootstrap')
-rwxr-xr-xqpid/cpp/bootstrap2
1 files changed, 1 insertions, 1 deletions
diff --git a/qpid/cpp/bootstrap b/qpid/cpp/bootstrap
index c443112f30..d1a4bcb6c0 100755
--- a/qpid/cpp/bootstrap
+++ b/qpid/cpp/bootstrap
@@ -11,7 +11,7 @@ export JAVA JAVAC
# Generate (for automake) lots of repetitive parts of tests/Makefile.am.
(cd src/tests && rm -f gen.mk
- perl -ne '/^include / or print' Makefile.am \
+ perl -ne '/^(include |if |else|endif)/ or print' Makefile.am \
| make -f - abs_srcdir=`dirname $(pwd)` gen.mk > /dev/null )
automake