summaryrefslogtreecommitdiff
path: root/qpid/cpp/bootstrap
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-21 02:08:18 +0000
committerAlan Conway <aconway@apache.org>2007-03-21 02:08:18 +0000
commitd2eb3361494710466280341c98f76c03536d2ebe (patch)
treef16ec2eacd8383e388657e54a22fc0214a0ce023 /qpid/cpp/bootstrap
parent732544fe86089ab86c03fcc48d5ca4c72667c275 (diff)
downloadqpid-python-d2eb3361494710466280341c98f76c03536d2ebe.tar.gz
Renamed cpp-0-9 to cpp
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@520706 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/bootstrap')
-rwxr-xr-xqpid/cpp/bootstrap39
1 files changed, 39 insertions, 0 deletions
diff --git a/qpid/cpp/bootstrap b/qpid/cpp/bootstrap
new file mode 100755
index 0000000000..4fbce77e3f
--- /dev/null
+++ b/qpid/cpp/bootstrap
@@ -0,0 +1,39 @@
+#!/bin/sh
+set -e
+aclocal -I m4
+autoheader
+libtoolize --automake
+
+# These are needed only if you don't already have the gen/*.{h,cpp} files.
+: ${JAVA=java}
+: ${JAVAC=javac}
+export JAVA JAVAC
+
+# If we're building in the qpid tree, we can generate
+# some Makefile snippets:
+
+if test -d ../specs; then
+ # Transform gen/Makefile.am, removing automake-constructs and the
+ # contents of the sole automake-else clause (the warning), then
+ # use the result to run the rules that create gen-src.mk, a file
+ # that must be created before we run automake.
+ (cd gen && rm -f gen-src.mk
+ perl -ne '/warning:|^(if|else|endif|include)\b/ or print' Makefile.am \
+ | make -f - srcdir=. gen-src.mk > /dev/null )
+fi
+
+# Generate (for automake) lots of repetitive parts of tests/Makefile.am.
+(cd tests && rm -f gen.mk
+ perl -ne '/^include / or print' Makefile.am \
+ | make -f - abs_srcdir=`dirname $(pwd)` gen.mk > /dev/null )
+
+automake
+autoconf
+
+
+if [ "$1" = "-build" -o "$1" = "--build" ] ; then
+ shift
+ ./configure "$@"
+ make
+ make check
+fi