summaryrefslogtreecommitdiff
path: root/qpid/cpp/examples/qmf-agent/Makefile
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2008-09-05 14:11:23 +0000
committerTed Ross <tross@apache.org>2008-09-05 14:11:23 +0000
commit67cb9d3c75bada36fae0086a04b6b1e9fc92459f (patch)
treecb2a0abae60bcaea0d1a3eac785ef8f6331fd238 /qpid/cpp/examples/qmf-agent/Makefile
parentab50ded1719791a6958442d3a7f9542488860911 (diff)
downloadqpid-python-67cb9d3c75bada36fae0086a04b6b1e9fc92459f.tar.gz
QPID-1274 - Improved packaging for management agent and code generation tool
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@692450 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/examples/qmf-agent/Makefile')
-rw-r--r--qpid/cpp/examples/qmf-agent/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/qpid/cpp/examples/qmf-agent/Makefile b/qpid/cpp/examples/qmf-agent/Makefile
index 0b37f1a295..6c4d9a867e 100644
--- a/qpid/cpp/examples/qmf-agent/Makefile
+++ b/qpid/cpp/examples/qmf-agent/Makefile
@@ -27,12 +27,10 @@ CC = gcc
LIB_DIR = $(QPID_DIR)/cpp/src/.libs
CC_INCLUDES = -I$(SRC_DIR) -I$(QPID_DIR)/cpp/src -I$(QPID_DIR)/cpp/src/gen -I$(GEN_DIR)
CC_FLAGS = -g -O3
-LD_FLAGS = -lqpidclient -lqpidcommon -L$(LIB_DIR)
+LD_FLAGS = -lqmfagent -L$(LIB_DIR)
SPEC_DIR = $(QPID_DIR)/specs
-TYPE_FILE = $(SPEC_DIR)/management-types.xml
MGEN_DIR = $(QPID_DIR)/cpp/managementgen
-TEMPLATE_DIR = $(MGEN_DIR)/templates
-MGEN = $(MGEN_DIR)/main.py
+MGEN = $(MGEN_DIR)/qmf-gen
vpath %.cpp $(SRC_DIR):$(GEN_DIR)
vpath %.d $(OBJ_DIR)
@@ -53,7 +51,7 @@ all: gen
@$(MAKE)
gen:
- $(MGEN) $(SCHEMA_FILE) $(TYPE_FILE) $(TEMPLATE_DIR) $(GEN_DIR)
+ $(MGEN) $(SCHEMA_FILE) $(GEN_DIR)
clean:
rm -rf $(GEN_DIR) $(OUT_FILE) *.d *.o