summaryrefslogtreecommitdiff
path: root/qpid/cpp/examples
diff options
context:
space:
mode:
authorTed Ross <tross@apache.org>2008-07-11 20:14:07 +0000
committerTed Ross <tross@apache.org>2008-07-11 20:14:07 +0000
commit2ebe3bcb668151cfd9a860e4416fe4478d9a56f4 (patch)
tree806288ff720f5b6bd73709e008e4f63c7e838896 /qpid/cpp/examples
parent525081bf3d3e9cb04cd9c7d3be030b4a2153be23 (diff)
downloadqpid-python-2ebe3bcb668151cfd9a860e4416fe4478d9a56f4.tar.gz
QPID-1174 Remote Management Agent for management of external components
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@676067 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/examples')
-rw-r--r--qpid/cpp/examples/qmf-agent/Makefile85
-rw-r--r--qpid/cpp/examples/qmf-agent/example.cpp97
-rw-r--r--qpid/cpp/examples/qmf-agent/schema.xml57
3 files changed, 239 insertions, 0 deletions
diff --git a/qpid/cpp/examples/qmf-agent/Makefile b/qpid/cpp/examples/qmf-agent/Makefile
new file mode 100644
index 0000000000..cc33dd1dc6
--- /dev/null
+++ b/qpid/cpp/examples/qmf-agent/Makefile
@@ -0,0 +1,85 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+SRC_DIR = .
+QPID_DIR = ../../..
+SCHEMA_FILE = $(SRC_DIR)/schema.xml
+GEN_DIR = $(SRC_DIR)/gen
+OUT_FILE = $(SRC_DIR)/qmf-agent
+
+CC = gcc
+LIB_DIR = $(QPID_DIR)/cpp/src/.libs
+CC_INCLUDES = -I$(SRC_DIR) -I$(QPID_DIR)/cpp/src -I$(QPID_DIR)/cpp/src/gen -I$(GEN_DIR)
+CC_FLAGS = -g -O2
+LD_FLAGS = -lqpidclient -lqpidcommon -L$(LIB_DIR)
+SPEC_DIR = $(QPID_DIR)/specs
+MGEN_DIR = $(QPID_DIR)/cpp/managementgen
+TEMPLATE_DIR = $(MGEN_DIR)/templates
+MGEN = $(MGEN_DIR)/main.py
+OBJ_DIR = $(SRC_DIR)/.libs
+
+vpath %.cpp $(SRC_DIR):$(GEN_DIR)
+vpath %.d $(OBJ_DIR)
+vpath %.o $(OBJ_DIR)
+
+cpps = $(wildcard $(SRC_DIR)/*.cpp)
+cpps += $(wildcard $(GEN_DIR)/*.cpp)
+deps = $(addsuffix .d, $(basename $(cpps)))
+objects = $(addsuffix .o, $(basename $(cpps)))
+
+.PHONY: all clean
+
+#==========================================================
+# Pass 0: generate source files from schema
+ifeq ($(MAKELEVEL), 0)
+
+all:
+ $(MGEN) $(SCHEMA_FILE) $(SPEC_DIR)/management-types.xml $(TEMPLATE_DIR) $(GEN_DIR)
+ $(MAKE)
+
+clean:
+ rm -rf $(GEN_DIR) $(OUT_FILE) *.d *.o
+
+
+#==========================================================
+# Pass 1: generate dependencies
+else ifeq ($(MAKELEVEL), 1)
+
+all: $(deps)
+ $(MAKE)
+
+%.d : %.cpp
+ $(CC) -M $(CC_FLAGS) $(CC_INCLUDES) $< > $@
+
+
+#==========================================================
+# Pass 2: build project
+else ifeq ($(MAKELEVEL), 2)
+
+$(OUT_FILE) : $(objects)
+ $(CC) -o $(OUT_FILE) $(CC_FLAGS) $(LD_FLAGS) $(objects)
+
+include $(deps)
+
+%.o : %.cpp
+ $(CC) -c $(CC_FLAGS) $(CC_INCLUDES) -o $@ $<
+
+endif
+
+
diff --git a/qpid/cpp/examples/qmf-agent/example.cpp b/qpid/cpp/examples/qmf-agent/example.cpp
new file mode 100644
index 0000000000..4113d22cac
--- /dev/null
+++ b/qpid/cpp/examples/qmf-agent/example.cpp
@@ -0,0 +1,97 @@
+/*
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one
+ * or more contributor license agreements. See the NOTICE file
+ * distributed with this work for additional information
+ * regarding copyright ownership. The ASF licenses this file
+ * to you under the Apache License, Version 2.0 (the
+ * "License"); you may not use this file except in compliance
+ * with the License. You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing,
+ * software distributed under the License is distributed on an
+ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ * KIND, either express or implied. See the License for the
+ * specific language governing permissions and limitations
+ * under the License.
+ *
+ */
+
+#include <qpid/management/Manageable.h>
+#include <qpid/management/ManagementObject.h>
+#include <qpid/agent/ManagementAgent.h>
+#include <qpid/agent/ManagementAgentImpl.h>
+#include "Parent.h"
+#include "PackageQmf_example.h"
+
+#include <unistd.h>
+#include <cstdlib>
+#include <iostream>
+
+#include <sstream>
+
+using namespace qpid::management;
+using namespace std;
+
+//==============================================================
+// CoreClass is the operational class that corresponds to the
+// "Parent" class in the management schema.
+//==============================================================
+class CoreClass : public Manageable
+{
+ string name;
+ Parent* mgmtObject;
+
+public:
+
+ CoreClass(ManagementAgent* agent, string _name);
+ ~CoreClass() {}
+
+ void bumpCounter() { mgmtObject->inc_count(); }
+
+ ManagementObject* GetManagementObject(void) const
+ { return mgmtObject; }
+};
+
+CoreClass::CoreClass(ManagementAgent* agent, string _name) : name(_name)
+{
+ mgmtObject = new Parent(agent, this, name);
+
+ agent->addObject(mgmtObject);
+ mgmtObject->set_state("IDLE");
+}
+
+
+//==============================================================
+// Main program
+//==============================================================
+int main(int argc, char** argv) {
+ const char* host = argc>1 ? argv[1] : "127.0.0.1";
+ int port = argc>2 ? atoi(argv[2]) : 5672;
+
+ // Create the qmf management agent
+ ManagementAgent* agent = new ManagementAgentImpl();
+
+ // Register the Qmf_example schema with the agent
+ PackageQmf_example packageInit(agent);
+
+ // Start the agent. It will attempt to make a connection to the
+ // management broker
+ agent->init (string(host), port);
+
+ // Allocate some core objects
+ CoreClass core1(agent, "Example Core Object #1");
+ CoreClass core2(agent, "Example Core Object #2");
+ CoreClass core3(agent, "Example Core Object #3");
+
+ // Periodically bump a counter in core1 to provide a changing statistical value
+ while (1)
+ {
+ sleep(1);
+ core1.bumpCounter();
+ }
+}
+
+
diff --git a/qpid/cpp/examples/qmf-agent/schema.xml b/qpid/cpp/examples/qmf-agent/schema.xml
new file mode 100644
index 0000000000..de8776c818
--- /dev/null
+++ b/qpid/cpp/examples/qmf-agent/schema.xml
@@ -0,0 +1,57 @@
+<schema package="qmf_example">
+
+<!--
+ Licensed to the Apache Software Foundation (ASF) under one
+ or more contributor license agreements. See the NOTICE file
+ distributed with this work for additional information
+ regarding copyright ownership. The ASF licenses this file
+ to you under the Apache License, Version 2.0 (the
+ "License"); you may not use this file except in compliance
+ with the License. You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing,
+ software distributed under the License is distributed on an
+ "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+ KIND, either express or implied. See the License for the
+ specific language governing permissions and limitations
+ under the License.
+-->
+
+ <!--
+ ===============================================================
+ Parent
+ ===============================================================
+ -->
+ <class name="Parent">
+
+ This class represents a parent object
+
+ <property name="name" type="sstr" access="RC" index="y"/>
+
+ <statistic name="state" type="sstr" desc="Operational state of the link"/>
+ <statistic name="count" type="count64" unit="tick" desc="Counter that increases monotonically"/>
+
+ <method name="create_child" desc="Create child object">
+ <arg name="name" dir="I" type="sstr"/>
+ <arg name="childRef" dir="O" type="objId"/>
+ </method>
+ </class>
+
+
+ <!--
+ ===============================================================
+ Child
+ ===============================================================
+ -->
+ <class name="Child">
+ <property name="ParentRef" type="objId" references="Parent" access="RC" index="y" parentRef="y"/>
+ <property name="name" type="sstr" access="RC" index="y"/>
+
+ <statistic name="count" type="count64" unit="tick" desc="Counter that increases monotonically"/>
+
+ <method name="delete"/>
+ </class>
+</schema>
+