summaryrefslogtreecommitdiff
path: root/qpid/cpp/examples
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2008-05-14 20:49:00 +0000
committerAlan Conway <aconway@apache.org>2008-05-14 20:49:00 +0000
commitcc156604be043fea4a195198e8a9f6dcb7233a6f (patch)
tree69cac29565459471e7d8230f58594a08efa8c497 /qpid/cpp/examples
parent4e8f8379172e827e7c68a741abe6c9c7f987c588 (diff)
downloadqpid-python-cc156604be043fea4a195198e8a9f6dcb7233a6f.tar.gz
Fix example check in rpmbuild.
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@656427 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/cpp/examples')
-rw-r--r--qpid/cpp/examples/Makefile.am2
-rwxr-xr-xqpid/cpp/examples/verify_all13
2 files changed, 7 insertions, 8 deletions
diff --git a/qpid/cpp/examples/Makefile.am b/qpid/cpp/examples/Makefile.am
index ccf7bf66ae..b046540b92 100644
--- a/qpid/cpp/examples/Makefile.am
+++ b/qpid/cpp/examples/Makefile.am
@@ -70,4 +70,4 @@ endif
# Verify the examples in the buid tree.
check-local: all-local verify
- $(srcdir)/verify_all $(abs_top_srcdir)/.. $(exclude_examples_regexp)
+ $(srcdir)/verify_all $(abs_top_srcdir)/.. $(top_builddir)/src/qpidd $(exclude_examples_regexp)
diff --git a/qpid/cpp/examples/verify_all b/qpid/cpp/examples/verify_all
index 0fc1625355..9db2214903 100755
--- a/qpid/cpp/examples/verify_all
+++ b/qpid/cpp/examples/verify_all
@@ -3,18 +3,17 @@
#
verify=`dirname $0`/verify
-topdir=$1
-exclude_regexp=$2
+topsrcdir=$1
+qpidd=$2
+exclude_regexp=$3
-
-qpidd=$topdir/cpp/src/qpidd
-python=$topdir/python
+python=$topsrcdir/python
trap "$qpidd -q" exit
-export QPID_PORT=`$qpidd -dp0 --data-dir "" --auth no`
+export QPID_PORT=`$qpidd -dp0 --data-dir "" --auth no` || { echo "Can't run qpidd" ; exit 1; }
export PYTHON_EXAMPLES=$python/examples
export PYTHONPATH=$python:$PYTHONPATH
-export AMQP_SPEC=$topdir/specs/amqp.0-10.xml
+export AMQP_SPEC=$topsrcdir/specs/amqp.0-10.xml
test -d $PYTHON_EXAMPLES || echo "Warning: not verifying python examples, $PYTHON_EXAMPLES not found"
find="find examples"