summaryrefslogtreecommitdiff
path: root/qpid/python/hello-world
diff options
context:
space:
mode:
authorAlan Conway <aconway@apache.org>2007-03-16 20:26:11 +0000
committerAlan Conway <aconway@apache.org>2007-03-16 20:26:11 +0000
commitc5b0c2b0eecd2e7335b44df7284f315cc7aae716 (patch)
tree2c4a5da4afb201f93057b0e6aa6475729612357c /qpid/python/hello-world
parentc68014801b3086b528a4e15cf3572f3633238d8a (diff)
downloadqpid-python-c5b0c2b0eecd2e7335b44df7284f315cc7aae716.tar.gz
Merged revisions 496593 via svnmerge from
https://svn.apache.org/repos/asf/incubator/qpid/branches/qpid.0-9 ........ r496593 | rhs | 2007-01-16 00:28:25 -0500 (Tue, 16 Jan 2007) | 1 line 0-9 request/response framing for python ........ git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@519129 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/python/hello-world')
-rwxr-xr-xqpid/python/hello-world11
1 files changed, 11 insertions, 0 deletions
diff --git a/qpid/python/hello-world b/qpid/python/hello-world
new file mode 100755
index 0000000000..b05873dff3
--- /dev/null
+++ b/qpid/python/hello-world
@@ -0,0 +1,11 @@
+#!/usr/bin/env python
+import qpid
+from qpid.client import Client
+from qpid.content import Content
+
+client = Client("127.0.0.1", 5672, qpid.spec.load("../specs/amqp.0-9.xml"))
+client.start({"LOGIN": "guest", "PASSWORD": "guest"})
+ch = client.channel(1)
+ch.channel_open()
+ch.message_transfer(destination="amq.direct", routing_key="asdf",
+ body="hello world")