summaryrefslogtreecommitdiff
path: root/qpid/python/hello-world
diff options
context:
space:
mode:
authorRafael H. Schloming <rhs@apache.org>2007-08-10 15:55:16 +0000
committerRafael H. Schloming <rhs@apache.org>2007-08-10 15:55:16 +0000
commitd1753304ae2248afbe7fad712a76ae87b4c0140a (patch)
treec18f882d1d62a10919d16e77bb7b517e1b0c9562 /qpid/python/hello-world
parent0ced84fe4947e2d2e37c0422aec7f6a2ac4ebd69 (diff)
downloadqpid-python-d1753304ae2248afbe7fad712a76ae87b4c0140a.tar.gz
added support for unpacked structs and execution.result
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@564637 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/python/hello-world')
-rwxr-xr-xqpid/python/hello-world12
1 files changed, 6 insertions, 6 deletions
diff --git a/qpid/python/hello-world b/qpid/python/hello-world
index 8b7a2752c5..4fb065ae53 100755
--- a/qpid/python/hello-world
+++ b/qpid/python/hello-world
@@ -3,13 +3,13 @@ import qpid
from qpid.client import Client
from qpid.content import Content
-client = Client("127.0.0.1", 5672, qpid.spec.load("../specs/amqp.0-9.xml",
- "../specs/amqp-errata.0-9.xml"))
+client = Client("127.0.0.1", 5672, qpid.spec.load("../specs/amqp.0-10-preview.xml"))
client.start({"LOGIN": "guest", "PASSWORD": "guest"})
ch = client.channel(1)
-ch.channel_open()
+ch.session_open()
ch.queue_declare(queue="test")
ch.queue_bind(exchange="amq.direct", queue="test", routing_key="test")
-ch.message_consume(queue="test", destination="test")
-ch.message_transfer(destination="amq.direct", routing_key="test",
- body="hello world")
+print ch.queue_query(queue="test")
+ch.message_subscribe(queue="test", destination="test")
+ch.message_transfer(destination="amq.direct",
+ content=Content("hello world"))