summaryrefslogtreecommitdiff
path: root/qpid/python/qpid/codec.py
diff options
context:
space:
mode:
authorGordon Sim <gsim@apache.org>2007-11-07 20:55:35 +0000
committerGordon Sim <gsim@apache.org>2007-11-07 20:55:35 +0000
commit1d31f66fcc9601db06f5fbdd158c16bc3180f0fd (patch)
tree17f200f059ca59b923f1371da863b14d1410d45e /qpid/python/qpid/codec.py
parent2e82ef59003f607e7ceea3442c423b4fc70001b9 (diff)
downloadqpid-python-1d31f66fcc9601db06f5fbdd158c16bc3180f0fd.tar.gz
Fix for QPID-639: c++ now includes sizes for all structs (enabled the same in python & java)
git-svn-id: https://svn.apache.org/repos/asf/incubator/qpid/trunk@592895 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid/python/qpid/codec.py')
-rw-r--r--qpid/python/qpid/codec.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/qpid/python/qpid/codec.py b/qpid/python/qpid/codec.py
index 6399ad2a5d..a3663773a9 100644
--- a/qpid/python/qpid/codec.py
+++ b/qpid/python/qpid/codec.py
@@ -434,7 +434,7 @@ class Codec:
raise ValueError("invalid width: %s" % width)
def encode_struct(self, type, s):
- if False and type.size:
+ if type.size:
enc = StringIO()
codec = Codec(enc, self.spec)
codec.encode_struct_body(type, s)
@@ -446,7 +446,7 @@ class Codec:
self.encode_struct_body(type, s)
def decode_struct(self, type):
- if False and type.size:
+ if type.size:
size = self.dec_num(type.size)
if size == 0:
return None