summaryrefslogtreecommitdiff
path: root/qpid
diff options
context:
space:
mode:
authorMichael Goulish <mgoulish@apache.org>2009-09-16 14:31:11 +0000
committerMichael Goulish <mgoulish@apache.org>2009-09-16 14:31:11 +0000
commitf12c10082f0cc95f53847b55b22c3f4476fea8a4 (patch)
treeb5524918ef6d488caa8275d2e1dfe98aea606f9e /qpid
parent4d41bdeef33634262c7bff6c5d3637a856653804 (diff)
downloadqpid-python-f12c10082f0cc95f53847b55b22c3f4476fea8a4.tar.gz
rhs's new system for python allows us to build python test
code that is appropriate for the installed python version, and place the code at any desired location. This is a big improvement in making the builds automatically adapt to different OSs. From src/tests/Makefile.am, I am calling his gadget to create the code, and placing it all in PYTHON_DIR/temp. Then altering the paths in a bunch of test scripts to point to the right places. git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@815804 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'qpid')
-rw-r--r--qpid/cpp/src/tests/Makefile.am7
-rwxr-xr-xqpid/cpp/src/tests/clustered_replication_test2
-rwxr-xr-xqpid/cpp/src/tests/federated_cluster_test2
-rwxr-xr-xqpid/cpp/src/tests/federated_topic_test2
-rwxr-xr-xqpid/cpp/src/tests/python_tests2
-rwxr-xr-xqpid/cpp/src/tests/reliable_replication_test2
-rwxr-xr-xqpid/cpp/src/tests/run_acl_tests2
-rwxr-xr-xqpid/cpp/src/tests/run_cli_tests4
-rwxr-xr-xqpid/cpp/src/tests/run_cluster_tests4
-rwxr-xr-xqpid/cpp/src/tests/run_federation_tests2
-rwxr-xr-xqpid/cpp/src/tests/run_header_test2
-rwxr-xr-xqpid/cpp/src/tests/run_ring_queue_test2
12 files changed, 20 insertions, 13 deletions
diff --git a/qpid/cpp/src/tests/Makefile.am b/qpid/cpp/src/tests/Makefile.am
index a15ba3578c..a95051fe95 100644
--- a/qpid/cpp/src/tests/Makefile.am
+++ b/qpid/cpp/src/tests/Makefile.am
@@ -349,3 +349,10 @@ EXTRA_DIST+=fanout_perftest shared_perftest multiq_perftest topic_perftest run_f
check-long:
$(MAKE) check TESTS="$(LONG_TESTS)" VALGRIND=
+
+all: python_prep
+
+python_prep :
+ ( cd ../../../python ; make install EXEC_PREFIX=temp PYTHON_LIB=temp AMQP_SPEC_DIR=$${PWD}/../specs )
+
+
diff --git a/qpid/cpp/src/tests/clustered_replication_test b/qpid/cpp/src/tests/clustered_replication_test
index cc331957ad..02698ebd86 100755
--- a/qpid/cpp/src/tests/clustered_replication_test
+++ b/qpid/cpp/src/tests/clustered_replication_test
@@ -22,7 +22,7 @@
# Test reliability of the replication feature in the face of link
# failures:
srcdir=`dirname $0`
-PYTHON_DIR=$srcdir/../../../python
+PYTHON_DIR=$srcdir/../../../python/temp
export PYTHONPATH=$PYTHON_DIR
trap stop_brokers INT EXIT
diff --git a/qpid/cpp/src/tests/federated_cluster_test b/qpid/cpp/src/tests/federated_cluster_test
index a781e269d6..871f3f7320 100755
--- a/qpid/cpp/src/tests/federated_cluster_test
+++ b/qpid/cpp/src/tests/federated_cluster_test
@@ -22,7 +22,7 @@
# Test reliability of the replication feature in the face of link
# failures:
srcdir=`dirname $0`
-PYTHON_DIR=$srcdir/../../../python
+PYTHON_DIR=$srcdir/../../../python/temp
trap stop_brokers EXIT
diff --git a/qpid/cpp/src/tests/federated_topic_test b/qpid/cpp/src/tests/federated_topic_test
index 21d8411eaf..3fcd89602c 100755
--- a/qpid/cpp/src/tests/federated_topic_test
+++ b/qpid/cpp/src/tests/federated_topic_test
@@ -43,7 +43,7 @@ while getopts "s:m:b:" opt ; do
done
MY_DIR=$(dirname $(which $0))
-PYTHON_DIR=${MY_DIR}/../../../python
+PYTHON_DIR=${MY_DIR}/../../../python/temp
trap stop_brokers EXIT
diff --git a/qpid/cpp/src/tests/python_tests b/qpid/cpp/src/tests/python_tests
index e3906c1685..aa13f329ed 100755
--- a/qpid/cpp/src/tests/python_tests
+++ b/qpid/cpp/src/tests/python_tests
@@ -22,7 +22,7 @@
# Run the python tests.
QPID_PORT=${QPID_PORT:-5672}
PYTHON_TESTS=${PYTHON_TESTS:-$*}
-QPID_PYTHON_DIR=${QPID_PYTHON_DIR:-`dirname $0`/../../../python}
+QPID_PYTHON_DIR=${QPID_PYTHON_DIR:-`dirname $0`/../../../python/temp}
FAILING=${FAILING:-/dev/null}
if test -d $QPID_PYTHON_DIR; then
diff --git a/qpid/cpp/src/tests/reliable_replication_test b/qpid/cpp/src/tests/reliable_replication_test
index a788d5a76b..11cdc5be66 100755
--- a/qpid/cpp/src/tests/reliable_replication_test
+++ b/qpid/cpp/src/tests/reliable_replication_test
@@ -22,7 +22,7 @@
# Test reliability of the replication feature in the face of link
# failures:
MY_DIR=`dirname \`which $0\``
-PYTHON_DIR=${MY_DIR}/../../../python
+PYTHON_DIR=${MY_DIR}/../../../python/temp
trap stop_brokers EXIT
diff --git a/qpid/cpp/src/tests/run_acl_tests b/qpid/cpp/src/tests/run_acl_tests
index d9b654c7cd..aef2879cbe 100755
--- a/qpid/cpp/src/tests/run_acl_tests
+++ b/qpid/cpp/src/tests/run_acl_tests
@@ -20,7 +20,7 @@
#
# Run the acl tests. $srcdir is set by the Makefile.
-PYTHON_DIR=$srcdir/../../../python
+PYTHON_DIR=$srcdir/../../../python/temp
DATA_DIR=`pwd`/data_dir
trap stop_brokers INT TERM QUIT
diff --git a/qpid/cpp/src/tests/run_cli_tests b/qpid/cpp/src/tests/run_cli_tests
index ea0d591176..e526c561f2 100755
--- a/qpid/cpp/src/tests/run_cli_tests
+++ b/qpid/cpp/src/tests/run_cli_tests
@@ -21,8 +21,8 @@
# Run the cli-utility tests.
MY_DIR=`dirname \`which $0\``
-PYTHON_DIR=${MY_DIR}/../../../python
-CLI_DIR=${PYTHON_DIR}/commands
+PYTHON_DIR=${MY_DIR}/../../../python/temp
+CLI_DIR=${PYTHON_DIR}
trap stop_brokers INT TERM QUIT
diff --git a/qpid/cpp/src/tests/run_cluster_tests b/qpid/cpp/src/tests/run_cluster_tests
index 8b039346db..c8fbe14c21 100755
--- a/qpid/cpp/src/tests/run_cluster_tests
+++ b/qpid/cpp/src/tests/run_cluster_tests
@@ -26,7 +26,7 @@ if [ -z ${top_builddir} -o -z ${srcdir} ]; then
top_builddir=${srcdir}/../../
fi
TEST_DIR=${top_builddir}/src/tests
-PYTHON_DIR=${srcdir}/../../../python
+PYTHON_DIR=${srcdir}/../../../python/temp
if test -z $1; then
CLUSTER_TEST="${PYTHON_DIR}/qpid-python-test -m cluster_tests cluster_tests.ShortTests.\*"
@@ -114,4 +114,4 @@ fi
# Delete cluster store dir if test was successful.
rm -rf ${TMP_DATA_DIR}
-exit 0 \ No newline at end of file
+exit 0
diff --git a/qpid/cpp/src/tests/run_federation_tests b/qpid/cpp/src/tests/run_federation_tests
index 8640fb728f..a003967322 100755
--- a/qpid/cpp/src/tests/run_federation_tests
+++ b/qpid/cpp/src/tests/run_federation_tests
@@ -21,7 +21,7 @@
# Run the federation tests.
MY_DIR=`dirname \`which $0\``
-PYTHON_DIR=${MY_DIR}/../../../python
+PYTHON_DIR=${MY_DIR}/../../../python/temp
trap stop_brokers INT TERM QUIT
diff --git a/qpid/cpp/src/tests/run_header_test b/qpid/cpp/src/tests/run_header_test
index 414fecd28f..729f300c53 100755
--- a/qpid/cpp/src/tests/run_header_test
+++ b/qpid/cpp/src/tests/run_header_test
@@ -24,7 +24,7 @@
# in both directions
srcdir=`dirname $0`
-PYTHON_DIR=$srcdir/../../../python
+PYTHON_DIR=$srcdir/../../../python/temp
test -f qpidd.port && QPID_PORT=`cat qpidd.port`
if test -d ${PYTHON_DIR} ; then
diff --git a/qpid/cpp/src/tests/run_ring_queue_test b/qpid/cpp/src/tests/run_ring_queue_test
index fb90075458..ad19a39d0f 100755
--- a/qpid/cpp/src/tests/run_ring_queue_test
+++ b/qpid/cpp/src/tests/run_ring_queue_test
@@ -22,7 +22,7 @@
#setup path to find qpid-config and sender/receiver test progs
srcdir=`dirname $0`
-PYTHON_DIR=$srcdir/../../../python
+PYTHON_DIR=$srcdir/../../../python/temp
export PYTHONPATH=$PYTHON_DIR
export PATH=./:$PYTHON_DIR/commands:$PATH