summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--qpid/cpp/CMakeLists.txt2
-rw-r--r--qpid/cpp/CTestCustom.cmake2
-rw-r--r--qpid/cpp/src/CMakeLists.txt1
3 files changed, 3 insertions, 2 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 12a0503398..796f587355 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -49,6 +49,8 @@ set (qpidc_version ${QPID_VERSION_FULL})
include(BuildInstallSettings.cmake)
+find_package(PythonInterp REQUIRED)
+
enable_testing()
include (CTest)
configure_file(${CMAKE_SOURCE_DIR}/CTestCustom.cmake ${CMAKE_BINARY_DIR}/CTestCustom.cmake)
diff --git a/qpid/cpp/CTestCustom.cmake b/qpid/cpp/CTestCustom.cmake
index 3d6bec1e33..0fcf2560b2 100644
--- a/qpid/cpp/CTestCustom.cmake
+++ b/qpid/cpp/CTestCustom.cmake
@@ -1 +1 @@
-set(CTEST_CUSTOM_PRE_TEST "${CMAKE_BINARY_DIR}/src/tests/check_dependencies.py")
+set(CTEST_CUSTOM_PRE_TEST "${PYTHON_EXECUTABLE} ${CMAKE_BINARY_DIR}/src/tests/check_dependencies.py")
diff --git a/qpid/cpp/src/CMakeLists.txt b/qpid/cpp/src/CMakeLists.txt
index be10be9b85..3b9bc472bc 100644
--- a/qpid/cpp/src/CMakeLists.txt
+++ b/qpid/cpp/src/CMakeLists.txt
@@ -36,7 +36,6 @@ include(CheckSizetDistinct)
find_package(PkgConfig)
find_package(Ruby)
-find_package(PythonInterp REQUIRED)
find_package(Doxygen)