summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--qpid/cpp/src/Makefile.am7
-rw-r--r--qpid/cpp/src/tests/README33
2 files changed, 12 insertions, 28 deletions
diff --git a/qpid/cpp/src/Makefile.am b/qpid/cpp/src/Makefile.am
index 564db08905..8b1c1d7246 100644
--- a/qpid/cpp/src/Makefile.am
+++ b/qpid/cpp/src/Makefile.am
@@ -79,7 +79,7 @@ posix_plat_hdr = \
platform_src = $(posix_plat_src)
platform_hdr = $(posix_plat_hdr)
-lib_LTLIBRARIES = libqpidcommon.la libqpidbroker.la libqpidclient.la libqpidamqp_0_10.la
+lib_LTLIBRARIES = libqpidcommon.la libqpidbroker.la libqpidclient.la
include cluster.mk
@@ -88,10 +88,12 @@ include cluster.mk
# unused parameters in boost::date_time headers. So we build it
# in a convenience library to link into libqpid_common.
#
-noinst_LTLIBRARIES=libLogger.la
+noinst_LTLIBRARIES=libLogger.la libqpidamqp_0_10.la
libLogger_la_SOURCES=qpid/log/Logger.cpp qpid/log/Logger.h
libLogger_la_CXXFLAGS=$(AM_CXXFLAGS) -Wno-unused-parameter
+# New 0-10 codec, to be integrated in future.
+# Currently built for tests only.
libqpidamqp_0_10_la_SOURCES= \
$(rgen_amqp_0_10_srcs) \
qpid/amqp_0_10/apply.h \
@@ -130,7 +132,6 @@ libqpidcommon_la_LIBADD = \
-lboost_filesystem \
-luuid \
libLogger.la \
- $(libqpidamqp_0_10_la_SOURCES) \
$(LIB_DLOPEN) \
$(LIB_CLOCK_GETTIME)
diff --git a/qpid/cpp/src/tests/README b/qpid/cpp/src/tests/README
index 3cf6fab2ad..0f4edee493 100644
--- a/qpid/cpp/src/tests/README
+++ b/qpid/cpp/src/tests/README
@@ -21,33 +21,16 @@ worked around in Qpid.
== Unit Tests ==
+Unit tests use the boost test framework, and are compiled to rogram
+ unit_test
+There are several options to control how test results are displayed,
+see
+ http://www.boost.org/doc/libs/1_35_0/libs/test/doc/components/utf/parameters/index.html
-Unit tests shared libraries containing CppUnit test plug-ins, run by
-the CppUnit DllPlugInTester program.
+NOTE: some unit tests are written as CppUnit plug-ins, we are moving away
+from CppUnit so new tests should use the boost framework.
-run-unit-tests runs tests under valgrind, you can run it directly.
-Library names (without path or .so) and CppUnit test paths can be
-specified on the command line or in env var UNIT_TESTS. For example:
-
-Selected test classes:
-./run-unit-tests ValueTest ClientChannelTest
-
-Individual test method
-./run-unit-tests ValueTest :ValueTest::testStringValueEquals
-
-You can also Build and run selected tests via make:
-make check TESTS=run-unit-tests UNIT_TESTS=ClientChannelTest
-
-NOTE: If you use DllPlugInTester directly note that if foobar.so is in
-the current directory then this will fail with "can't load plugin":
- # DllPluginTester foobar.so
-
-Instead you need to say:
- # DllPluginTester ./foobar.so
-
-DllPluginTester uses dlopen() which only searches for shlibs
-in the standard places unless the filename contains a "/". In that
-case it just tries to open the filename.
+CppUnit tests are run by the script run-unit-tests.
== System Tests ==