summaryrefslogtreecommitdiff
path: root/cpp/bindings/qmf/ruby
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/bindings/qmf/ruby')
-rw-r--r--cpp/bindings/qmf/ruby/CMakeLists.txt6
-rw-r--r--cpp/bindings/qmf/ruby/Makefile.am2
-rw-r--r--cpp/bindings/qmf/ruby/qmf.rb14
-rw-r--r--cpp/bindings/qmf/ruby/ruby.i2
4 files changed, 9 insertions, 15 deletions
diff --git a/cpp/bindings/qmf/ruby/CMakeLists.txt b/cpp/bindings/qmf/ruby/CMakeLists.txt
index 702606139b..1fb2542e46 100644
--- a/cpp/bindings/qmf/ruby/CMakeLists.txt
+++ b/cpp/bindings/qmf/ruby/CMakeLists.txt
@@ -22,7 +22,9 @@
##------------------------------------------------------
set_source_files_properties(${CMAKE_CURRENT_SOURCE_DIR}/ruby.i PROPERTIES CPLUSPLUS ON)
-include_directories(${RUBY_INCLUDE_DIRS} ${qpid-cpp_SOURCE_DIR}/include)
+include_directories(${RUBY_INCLUDE_DIRS}
+ ${qpid-cpp_SOURCE_DIR}/include
+ ${qpid-cpp_SOURCE_DIR}/bindings)
swig_add_module(qmfengine_ruby ruby ${CMAKE_CURRENT_SOURCE_DIR}/ruby.i)
swig_link_libraries(qmfengine_ruby qmf qmfconsole ${RUBY_LIBRARY})
@@ -32,6 +34,6 @@ swig_link_libraries(qmfengine_ruby qmf qmfconsole ${RUBY_LIBRARY})
##----------------------------------
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libqmfengine_ruby.so
RENAME qmfengine.so
- DESTINATION ${RUBY_ARCH_DIR}
+ DESTINATION ${RUBY_PFX_ARCH_DIR}
COMPONENT ${QPID_COMPONENT_CLIENT}
)
diff --git a/cpp/bindings/qmf/ruby/Makefile.am b/cpp/bindings/qmf/ruby/Makefile.am
index 1c7f67edb3..33393aeda0 100644
--- a/cpp/bindings/qmf/ruby/Makefile.am
+++ b/cpp/bindings/qmf/ruby/Makefile.am
@@ -29,7 +29,7 @@ rubylibdir = $(RUBY_LIB)
dist_rubylib_DATA = qmf.rb
-qmfengine.cpp: $(srcdir)/ruby.i $(srcdir)/../qmfengine.i
+qmfengine.cpp: $(srcdir)/ruby.i
$(SWIG) -ruby -c++ $(SWIG_FLAGS) $(INCLUDES) $(QPID_CXXFLAGS) -I/usr/include -o qmfengine.cpp $(srcdir)/ruby.i
rubylibarchdir = $(RUBY_LIB_ARCH)
diff --git a/cpp/bindings/qmf/ruby/qmf.rb b/cpp/bindings/qmf/ruby/qmf.rb
index 9fbd50cbf6..d05127db4b 100644
--- a/cpp/bindings/qmf/ruby/qmf.rb
+++ b/cpp/bindings/qmf/ruby/qmf.rb
@@ -319,9 +319,7 @@ module Qmf
eventImpl.sessionContext.handler.sess_event_recv(eventImpl.sessionContext, eventImpl.message)
end
rescue Exception => ex
- puts "Event Exception: #{ex}"
if bt_count < 2
- puts ex.backtrace
bt_count += 1
end
end
@@ -1251,9 +1249,7 @@ module Qmf
when Qmfengine::ConsoleEvent::METHOD_RESPONSE
end
rescue Exception => ex
- puts "Exception caught in callback: #{ex}"
if @bt_count < 2
- puts ex.backtrace
@bt_count += 1
end
end
@@ -1381,14 +1377,13 @@ module Qmf
end
def conn_event_connected()
- puts "Console Connection Established..."
@session = Session.new(@conn, "qmfc-%s.%d" % [Socket.gethostname, Process::pid], self)
@impl.sessionOpened(@session.handle)
do_events
end
def conn_event_disconnected(error)
- puts "Console Connection Lost"
+
end
def conn_event_visit
@@ -1396,12 +1391,10 @@ module Qmf
end
def sess_event_session_closed(context, error)
- puts "Console Session Lost"
@impl.sessionClosed()
end
def sess_event_recv(context, message)
- puts "Unexpected RECV Event" if not @operational
@impl.handleRcvMessage(message)
do_events
end
@@ -1510,14 +1503,13 @@ module Qmf
end
def conn_event_connected()
- puts "Agent Connection Established..."
@session = Session.new(@conn, "qmfa-%s.%d" % [Socket.gethostname, Process::pid], self)
@impl.newSession
do_events
end
def conn_event_disconnected(error)
- puts "Agent Connection Lost"
+
end
def conn_event_visit
@@ -1525,7 +1517,7 @@ module Qmf
end
def sess_event_session_closed(context, error)
- puts "Agent Session Lost"
+
end
def sess_event_recv(context, message)
diff --git a/cpp/bindings/qmf/ruby/ruby.i b/cpp/bindings/qmf/ruby/ruby.i
index 0101861100..2854aa0c7e 100644
--- a/cpp/bindings/qmf/ruby/ruby.i
+++ b/cpp/bindings/qmf/ruby/ruby.i
@@ -102,5 +102,5 @@
}
-%include "../qmfengine.i"
+%include "qmf/qmfengine.i"