summaryrefslogtreecommitdiff
path: root/cpp/bindings/qpid/perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/bindings/qpid/perl/Makefile.PL')
-rw-r--r--cpp/bindings/qpid/perl/Makefile.PL13
1 files changed, 13 insertions, 0 deletions
diff --git a/cpp/bindings/qpid/perl/Makefile.PL b/cpp/bindings/qpid/perl/Makefile.PL
new file mode 100644
index 0000000000..7a4d7f03dc
--- /dev/null
+++ b/cpp/bindings/qpid/perl/Makefile.PL
@@ -0,0 +1,13 @@
+#!/usr/bin/perl -w
+
+use strict;
+
+use ExtUtils::MakeMaker;
+use Config;
+
+WriteMakefile(
+ NAME => 'cqpid_perl',
+ PREREQ_PM => {},
+ LIBS => ["-lqpidmessaging -lqpidtypes"],
+ C => ['cqpid_perl.cpp'],
+);