summaryrefslogtreecommitdiff
path: root/cpp/docs/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/docs/api/CMakeLists.txt')
-rw-r--r--cpp/docs/api/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/cpp/docs/api/CMakeLists.txt b/cpp/docs/api/CMakeLists.txt
index 21e6f51caf..828d706b91 100644
--- a/cpp/docs/api/CMakeLists.txt
+++ b/cpp/docs/api/CMakeLists.txt
@@ -30,11 +30,13 @@ if (GEN_DOXYGEN)
${CMAKE_CURRENT_BINARY_DIR}/developer.doxygen)
add_custom_target (docs-user-api COMMAND ${DOXYGEN_EXECUTABLE} user.doxygen)
add_custom_target (docs-developer COMMAND ${DOXYGEN_EXECUTABLE} developer.doxygen)
+ add_dependencies (docs docs-developer docs-user-api)
# HTML files are generated to ./html - put those in the install.
install (DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html/
- DESTINATION ${QPID_INSTALL_HTMLDIR}
- COMPONENT ${QPID_COMPONENT_CLIENT_INCLUDE})
+ DESTINATION ${QPID_INSTALL_DOCDIR}/api/html
+ COMPONENT ${QPID_COMPONENT_CLIENT_INCLUDE}
+ ${OPTIONAL_ARG})
if (CPACK_GENERATOR STREQUAL "NSIS")
set (CPACK_NSIS_MENU_LINKS
"${QPID_INSTALL_HTMLDIR}/index.html" "Qpid C++ API Documentation"