summaryrefslogtreecommitdiff
path: root/cpp/examples/old_api/xml-exchange/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/examples/old_api/xml-exchange/Makefile.am')
-rw-r--r--cpp/examples/old_api/xml-exchange/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/cpp/examples/old_api/xml-exchange/Makefile.am b/cpp/examples/old_api/xml-exchange/Makefile.am
index 3e1082cdb2..d4bc6ba233 100644
--- a/cpp/examples/old_api/xml-exchange/Makefile.am
+++ b/cpp/examples/old_api/xml-exchange/Makefile.am
@@ -24,13 +24,13 @@ include $(top_srcdir)/examples/makedist.mk
noinst_PROGRAMS=declare_queues xml_producer listener
declare_queues_SOURCES=declare_queues.cpp
-declare_queues_LDADD=$(CLIENT_LIB)
+declare_queues_LDADD=$(CLIENT_LIB) $(COMMON_LIB)
xml_producer_SOURCES=xml_producer.cpp
-xml_producer_LDADD=$(CLIENT_LIB)
+xml_producer_LDADD=$(CLIENT_LIB) $(COMMON_LIB)
listener_SOURCES=listener.cpp
-listener_LDADD=$(CLIENT_LIB)
+listener_LDADD=$(CLIENT_LIB) $(COMMON_LIB)
EXTRA_DIST= \
README.txt \