summaryrefslogtreecommitdiff
path: root/qpid/cpp/docs/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/docs/api/Makefile.am')
-rw-r--r--qpid/cpp/docs/api/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/qpid/cpp/docs/api/Makefile.am b/qpid/cpp/docs/api/Makefile.am
new file mode 100644
index 0000000000..3dd78ae7ad
--- /dev/null
+++ b/qpid/cpp/docs/api/Makefile.am
@@ -0,0 +1,40 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+#
+# Run doxygen to generate HTML doc.
+# Generate dependency files so its rebuilt only when needed.
+#
+
+if HAVE_DOXYGEN
+
+EXTRA_DIST = html user.doxygen developer.doxygen html.timestamp CMakeLists.txt \
+ header.html footer.html
+
+html: html.timestamp
+
+
+html.timestamp:
+ test $(srcdir) = . || cp $(srcdir)/header.html $(srcdir)/footer.html .
+ doxygen user.doxygen
+ touch $@
+
+clean-local:
+ rm -rf html html-dev html.timestamp
+
+endif