summaryrefslogtreecommitdiff
path: root/qpid/cpp/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/examples/Makefile.am')
-rw-r--r--qpid/cpp/examples/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/qpid/cpp/examples/Makefile.am b/qpid/cpp/examples/Makefile.am
new file mode 100644
index 0000000000..6b2bb73587
--- /dev/null
+++ b/qpid/cpp/examples/Makefile.am
@@ -0,0 +1,37 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+SUBDIRS = qmf-console messaging old_api
+
+MAKEDIST=.libs/Makefile
+
+$(MAKEDIST): Makefile
+ mkdir -p .libs
+ @(echo 'all clean:' ; \
+ echo ' for d in $(SUBDIRS) ; do $$(MAKE) -C $$$$d $$@ ; done' ; \
+ ) > $(MAKEDIST)
+
+examplesdir=$(pkgdatadir)/examples
+dist_examples_DATA = README.txt $(MAKEDIST)
+
+EXTRA_DIST = examples.sln CMakeLists.txt
+
+# For older versions of automake
+abs_top_srcdir = @abs_top_srcdir@
+abs_top_builddir = @abs_top_builddir@
+