summaryrefslogtreecommitdiff
path: root/qpid/cpp/examples/messaging/extra_dist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/examples/messaging/extra_dist/Makefile')
-rw-r--r--qpid/cpp/examples/messaging/extra_dist/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/qpid/cpp/examples/messaging/extra_dist/Makefile b/qpid/cpp/examples/messaging/extra_dist/Makefile
new file mode 100644
index 0000000000..8dd7f658f7
--- /dev/null
+++ b/qpid/cpp/examples/messaging/extra_dist/Makefile
@@ -0,0 +1,30 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+CXX=g++
+CXXFLAGS=-g -O2
+LDFLAGS=-lqpidmessaging
+
+all: drain spout client server map_sender map_receiver hello_world
+
+drain: drain.o OptionParser.o
+
+spout: spout.o OptionParser.o
+
+clean:
+ rm -f drain spout client server map_sender map_receiver hello_world *.o