summaryrefslogtreecommitdiff
path: root/qpid/cpp/rpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/rpm/Makefile.am')
-rw-r--r--qpid/cpp/rpm/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/qpid/cpp/rpm/Makefile.am b/qpid/cpp/rpm/Makefile.am
new file mode 100644
index 0000000000..46c071ec87
--- /dev/null
+++ b/qpid/cpp/rpm/Makefile.am
@@ -0,0 +1,25 @@
+#
+# Build RPMs from the distribution tarball.
+#
+
+# TODO aconway 2006-12-21: use autoconf macros for version, base name etc.
+
+SPEC=${top_srcdir}/qpidc.spec
+RPMOPTS=--define "_sourcedir ${abs_top_srcdir}" --define "_topdir ${abs_builddir}"
+
+clean:
+ rm -rf BUILD RPMS SOURCES SPECS SRPMS
+
+.PHONY: rpm srpm dist
+
+# Build source and binary RPMs.
+rpm: dist
+ rpmbuild $(RPMOPTS) -ba $(SPEC)
+
+# Source RPM only.
+srpm: dist
+ rpmbuild $(RPMOPTS) -bs $(SPEC)
+
+# Build source distribution.
+dist:
+ cd .. && $(MAKE) $(AM_MAKEFLAGS) dist