summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/acl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/src/acl.mk')
-rw-r--r--qpid/cpp/src/acl.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/qpid/cpp/src/acl.mk b/qpid/cpp/src/acl.mk
new file mode 100644
index 0000000000..b8e2ff0e13
--- /dev/null
+++ b/qpid/cpp/src/acl.mk
@@ -0,0 +1,41 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+#
+# acl library makefile fragment, to be included in Makefile.am
+#
+dmoduleexec_LTLIBRARIES += acl.la
+
+acl_la_SOURCES = \
+ qpid/acl/Acl.cpp \
+ qpid/acl/Acl.h \
+ qpid/acl/AclData.cpp \
+ qpid/acl/AclData.h \
+ qpid/acl/AclPlugin.cpp \
+ qpid/acl/AclReader.cpp \
+ qpid/acl/AclReader.h \
+ qpid/acl/AclValidator.cpp \
+ qpid/acl/AclValidator.h
+
+acl_la_LIBADD = libqpidbroker.la
+if SUNOS
+ acl_la_LIBADD += libqmfagent.la libqmfconsole.la libqpidcommon.la -lboost_program_options $(SUNCC_RUNTIME_LIBS)
+endif
+
+acl_la_LDFLAGS = $(PLUGINLDFLAGS)
+