summaryrefslogtreecommitdiff
path: root/qpid/cpp/src/xml.mk
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp/src/xml.mk')
-rw-r--r--qpid/cpp/src/xml.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/qpid/cpp/src/xml.mk b/qpid/cpp/src/xml.mk
new file mode 100644
index 0000000000..baf3803647
--- /dev/null
+++ b/qpid/cpp/src/xml.mk
@@ -0,0 +1,29 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+dmoduleexec_LTLIBRARIES += xml.la
+
+xml_la_SOURCES = \
+ qpid/xml/XmlExchange.cpp \
+ qpid/xml/XmlExchange.h \
+ qpid/xml/XmlExchangePlugin.cpp
+
+xml_la_LIBADD = -lxerces-c -lxqilla libqpidbroker.la
+
+xml_la_LDFLAGS = $(PLUGINLDFLAGS)
+