summaryrefslogtreecommitdiff
path: root/qpid/cpp
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/cpp')
-rw-r--r--qpid/cpp/CMakeLists.txt2
-rw-r--r--qpid/cpp/CMakeModules/FindProton.cmake70
-rw-r--r--qpid/cpp/src/qpid/linearstore/journal/jdir.cpp1
3 files changed, 73 insertions, 0 deletions
diff --git a/qpid/cpp/CMakeLists.txt b/qpid/cpp/CMakeLists.txt
index 837a71cd44..d057254d45 100644
--- a/qpid/cpp/CMakeLists.txt
+++ b/qpid/cpp/CMakeLists.txt
@@ -29,6 +29,8 @@ else()
set (OPTIONAL_ARG OPTIONAL)
endif()
+set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMakeModules)
+
# Parse the version from QPID_VERSION.txt.
# Use the top level qpid/ file if we're in an SVN checkout, source dir otherwise.
find_file(QPID_VERSION_FILE NAMES QPID_VERSION.txt PATHS ${PROJECT_SOURCE_DIR}/.. ${PROJECT_SOURCE_DIR} NO_DEFAULT_PATH)
diff --git a/qpid/cpp/CMakeModules/FindProton.cmake b/qpid/cpp/CMakeModules/FindProton.cmake
new file mode 100644
index 0000000000..e6eae5d9d9
--- /dev/null
+++ b/qpid/cpp/CMakeModules/FindProton.cmake
@@ -0,0 +1,70 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+include(FindPackageHandleStandardArgs)
+include(FindPackageMessage)
+
+# First try to find the Installed Proton config (Proton 0.7 and later)
+find_package(Proton QUIET NO_MODULE)
+if (Proton_FOUND)
+ find_package_message(Proton "Found Proton: ${Proton_LIBRARIES} (found version \"${Proton_VERSION}\")" "$Proton_DIR ${Proton_LIBRARIES} $Proton_VERSION")
+ return()
+endif ()
+
+# Now look for the cooky Proton config installed with some earlier
+# versions of Proton
+find_package(proton QUIET NO_MODULE)
+if (proton_FOUND)
+ include("${proton_DIR}/libqpid-proton.cmake")
+ set (Proton_VERSION ${PROTON_VERSION})
+ set (Proton_INCLUDE_DIRS ${PROTON_INCLUDE_DIRS})
+ set (Proton_LIBRARIES ${PROTON_LIBRARIES})
+ set (Proton_FOUND true)
+ find_package_message(Proton "Found Proton: ${Proton_LIBRARIES} (found version \"${Proton_VERSION}\")" "$Proton_DIR ${Proton_LIBRARIES} $Proton_VERSION")
+ return()
+endif ()
+
+# Now look for any pkg-config configuration
+find_package(PkgConfig QUIET)
+
+if (PKG_CONFIG_FOUND)
+ # Check for cmake 2.6
+ if (NOT ${CMAKE_VERSION} VERSION_LESS "2.8.0")
+ set (FindPkgQUIET QUIET)
+ endif()
+
+ if (NOT Proton_FIND_VERSION)
+ pkg_check_modules(Proton ${FindPkgQUIET} libqpid-proton)
+ elseif(NOT Proton_FIND_VERSION_EXACT)
+ pkg_check_modules(Proton ${FindPkgQUIET} libqpid-proton>=${Proton_FIND_VERSION})
+ else()
+ pkg_check_modules(Proton ${FindPkgQUIET} libqpid-proton=${Proton_FIND_VERSION})
+ endif()
+ if (Proton_FOUND)
+ find_library(Proton_LIBRARY ${Proton_LIBRARIES} HINTS ${Proton_LIBRARY_DIRS})
+ set (Proton_LIBRARIES ${Proton_LIBRARY})
+ find_package_message(Proton "Found Proton: ${Proton_LIBRARIES} (found version \"${Proton_VERSION}\")" "$Proton_DIR ${Proton_LIBRARIES} $Proton_VERSION")
+ return()
+ endif ()
+endif()
+
+# Proton not found print a standard error message
+if (NOT ${CMAKE_VERSION} VERSION_LESS "2.8.0")
+ find_package_handle_standard_args(Proton CONFIG_MODE)
+endif()
diff --git a/qpid/cpp/src/qpid/linearstore/journal/jdir.cpp b/qpid/cpp/src/qpid/linearstore/journal/jdir.cpp
index 36f180c21f..72b94d0098 100644
--- a/qpid/cpp/src/qpid/linearstore/journal/jdir.cpp
+++ b/qpid/cpp/src/qpid/linearstore/journal/jdir.cpp
@@ -104,6 +104,7 @@ jdir::clear_dir(const std::string& dirname/*, const std::string&
DIR* dir = open_dir(dirname, "clear_dir", true);
if (!dir && create_flag) {
create_dir(dirname);
+ dir = open_dir(dirname, "clear_dir", true);
}
//#ifndef RHM_JOWRITE
struct dirent* entry;