summaryrefslogtreecommitdiff
path: root/qpid/doc/book/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/doc/book/Makefile')
-rw-r--r--qpid/doc/book/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/qpid/doc/book/Makefile b/qpid/doc/book/Makefile
new file mode 100644
index 0000000000..6e97a0c5cc
--- /dev/null
+++ b/qpid/doc/book/Makefile
@@ -0,0 +1,38 @@
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+
+DIRS = src/cpp-broker src/programming
+
+
+.PHONY: all $(DIRS)
+
+all: $(DIRS)
+
+clean:
+ rm -rf build
+
+html: TARGET = html
+html: all
+
+pdf: TARGET = pdf
+pdf: all
+
+$(DIRS):
+ $(MAKE) -C $@ $(TARGET) OUTPUTDIR=../../build/
+