summaryrefslogtreecommitdiff
path: root/qpid/extras/qmf/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'qpid/extras/qmf/setup.py')
-rwxr-xr-xqpid/extras/qmf/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/qpid/extras/qmf/setup.py b/qpid/extras/qmf/setup.py
new file mode 100755
index 0000000000..e7bf4b9717
--- /dev/null
+++ b/qpid/extras/qmf/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/env python
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+#
+from distutils.core import setup
+
+setup(name="qpid-qmf",
+ version="0.11",
+ author="Apache Qpid",
+ author_email="dev@qpid.apache.org",
+ packages=["qmf"],
+ package_dir={"": "src/py"},
+ url="http://qpid.apache.org/",
+ license="Apache Software License",
+ description="QMF Library")