summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2015-10-15 23:32:51 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-10-15 23:32:51 -0700
commit67ecc1f7a63827078916e4c3552db54865cbc8c2 (patch)
tree7184b87957bb0fcbd91b8cec8580b6a03fae0214
parent17410d968b890d1545b84debf0f83059f2aabdeb (diff)
downloadrabbitmq-c-cmp0042.tar.gz
CMake: Set CMP0042 to use NEW policy.cmp0042
Fixes #293
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0e8c87..152e7bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,10 @@
cmake_minimum_required(VERSION 2.6)
project(rabbitmq-c "C")
+if (POLICY CMP0042)
+ cmake_policy(SET CMP0042 NEW)
+endif()
+
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# Follow all steps below in order to calculate new ABI version when updating the library