summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEduard Egorov <egorov3758@gmail.com>2018-03-23 13:18:11 +0300
committerAlan Antonuk <alan.antonuk@gmail.com>2018-03-28 10:42:46 -0700
commita4e23c08738326f59a02bd0e645ec7ab7c34e3dd (patch)
tree61b8bb4ef2d1588f0bed375ea6b57a6eb791fa77
parenta63f47e6f1cc1c4a65106fbadcbf3fa66e9ee489 (diff)
downloadrabbitmq-c-pr487.tar.gz
examples: fix building against static librabbitmq.pr487
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index f49bc7a..4ea8e93 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,3 +1,7 @@
+if (NOT BUILD_SHARED_LIBS)
+ add_definitions(-DAMQP_STATIC)
+endif()
+
include_directories(${LIBRABBITMQ_INCLUDE_DIRS})
if (WIN32)