summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2016-04-09 21:58:07 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2016-04-09 22:03:24 -0700
commitcaad0ef1533783729c7644a226c989c79b4c497b (patch)
tree95467ec09314d33cce1191583183a26039544c13
parent6d8726ce1cb0d1ebbaa927be4353f9189dabeda8 (diff)
downloadrabbitmq-c-release_080.tar.gz
Preparation for v0.8.0 release.v0.8.0release_080
-rw-r--r--CMakeLists.txt6
-rw-r--r--ChangeLog.md30
-rw-r--r--README.md4
-rw-r--r--configure.ac6
-rw-r--r--librabbitmq/amqp.h2
5 files changed, 39 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 908f02f..ef6c0c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,9 +17,9 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# 3. If any interfaces have been added since the last public release, then increment age.
# 4. If any interfaces have been removed since the last public release, then set age to 0.
-set(RMQ_SOVERSION_CURRENT 5)
-set(RMQ_SOVERSION_REVISION 4)
-set(RMQ_SOVERSION_AGE 1)
+set(RMQ_SOVERSION_CURRENT 6)
+set(RMQ_SOVERSION_REVISION 0)
+set(RMQ_SOVERSION_AGE 2)
math(EXPR RMQ_SOVERSION_MAJOR "${RMQ_SOVERSION_CURRENT} - ${RMQ_SOVERSION_AGE}")
math(EXPR RMQ_SOVERSION_MINOR "${RMQ_SOVERSION_AGE}")
diff --git a/ChangeLog.md b/ChangeLog.md
index 21d6c2c..0350e7e 100644
--- a/ChangeLog.md
+++ b/ChangeLog.md
@@ -1,4 +1,34 @@
# Change Log
+## v0.8.0 - 2016-04-09
+### Added:
+- SSL: peer certificate and hostname validation can now be controlled separately
+ using `amqp_ssl_socket_set_verify_peer` and
+ `amqp_ssl_socket_set_verify_hostname`.
+- SSL: the desire SSL version range can now be specified using the
+ `amqp_ssl_socket_set_ssl_versions` function.
+- Add flags to SSL examples on controlling hostname verification.
+
+### Changed:
+- SSL: SSLv2, and SSLv3 have been disabled by default.
+- SSL: OpenSSL hostname validation has been improved.
+- Win32 debug information is built with /Z7 on MSVC to embed debug info instead
+ of using a .pdb
+
+### Fixed:
+- Connection failure results in hang on Win32 (#297, #346)
+- Rabbitmq-c may block when attempting to close an SSL socket (#313)
+- amqp_parse_url does not correctly initialize default parameters (#319)
+- x509 objects are leaked in verify_hostname (#323)
+- TCP_NOPUSH doesn't work under cygwin (#335)
+
+### Deprecated
+- SSL: `amqp_ssl_socket_set_verify` is being replaced by
+ `amqp_ssl_socket_set_verify_peer` and `amqp_ssl_socket_set_verify_hostname`.
+
+### Removed:
+- OpenVMS build system and related files.
+- Unmaintained PolarSSL, CyaSSL, and gnuTLS SSL backends
+
## Changes since v0.7.0 (a.k.a., v0.7.1)
- `41fa9df` Autoconf: add missing files in build system
- `ef73c06` Win32: Use WSAEWOULDBLOCK instead of EWOULDBLOCK on Win32
diff --git a/README.md b/README.md
index 3675183..c4b55a9 100644
--- a/README.md
+++ b/README.md
@@ -22,9 +22,9 @@ The latest stable release of rabbitmq-c can be found at:
## Documentation
-API documentation for v0.5.0+ can viewed from:
+API documentation for v0.8.0+ can viewed from:
-<http://alanxz.github.io/rabbitmq-c/docs/0.5.0/>
+<http://alanxz.github.io/rabbitmq-c/docs/0.8.0/>
## Getting started
diff --git a/configure.ac b/configure.ac
index ce094b8..a5c47fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,9 +12,9 @@ m4_define([micro_version], [0])
# 2. If any interfaces have been added, removed, or changed since the last update, increment current and set revision to 0.
# 3. If any interfaces have been added since the last public release, then increment age.
# 4. If any interfaces have been removed since the last public release, then set age to 0.
-m4_define([soversion_current], [5])
-m4_define([soversion_revision], [4])
-m4_define([soversion_age], [1])
+m4_define([soversion_current], [6])
+m4_define([soversion_revision], [0])
+m4_define([soversion_age], [2])
AC_INIT([rabbitmq-c], [major_version.minor_version.micro_version],
[https://github.com/alanxz/rabbitmq-c/issues], [rabbitmq-c],
diff --git a/librabbitmq/amqp.h b/librabbitmq/amqp.h
index 724c8f5..e95b8a7 100644
--- a/librabbitmq/amqp.h
+++ b/librabbitmq/amqp.h
@@ -225,7 +225,7 @@ AMQP_BEGIN_DECLS
#define AMQP_VERSION_MAJOR 0
#define AMQP_VERSION_MINOR 8
#define AMQP_VERSION_PATCH 0
-#define AMQP_VERSION_IS_RELEASE 0
+#define AMQP_VERSION_IS_RELEASE 1
/**