summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Steinert <mike.steinert@gmail.com>2012-12-03 12:53:53 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2013-04-09 15:54:49 -0700
commit173e563d3fcd87a03a65a9444d284d71a121e5b4 (patch)
treec0fddf724598fd29ae52ab704b9dec1985daf221
parent12e068b65110f1780379459b96c28a4f5662109e (diff)
downloadrabbitmq-c-173e563d3fcd87a03a65a9444d284d71a121e5b4.tar.gz
Start addressing review comments
Signed-off-by: Michael Steinert <mike.steinert@gmail.com>
-rw-r--r--Makefile.am14
-rw-r--r--examples/amqp_bind.c2
-rw-r--r--examples/amqp_consumer.c2
-rw-r--r--examples/amqp_exchange_declare.c2
-rw-r--r--examples/amqp_listen.c2
-rw-r--r--examples/amqp_listenq.c2
-rw-r--r--examples/amqp_producer.c2
-rw-r--r--examples/amqp_rpc_sendstring_client.c2
-rw-r--r--examples/amqp_sendstring.c2
-rw-r--r--examples/amqp_unbind.c2
-rw-r--r--examples/amqps_bind.c2
-rw-r--r--examples/amqps_consumer.c2
-rw-r--r--examples/amqps_exchange_declare.c2
-rw-r--r--examples/amqps_listen.c2
-rw-r--r--examples/amqps_listenq.c2
-rw-r--r--examples/amqps_producer.c2
-rw-r--r--examples/amqps_sendstring.c2
-rw-r--r--examples/amqps_unbind.c2
-rw-r--r--librabbitmq/CMakeLists.txt10
-rw-r--r--librabbitmq/amqp_connection.c2
-rw-r--r--librabbitmq/amqp_cyassl.c (renamed from librabbitmq/amqp-cyassl.c)2
-rw-r--r--librabbitmq/amqp_gnutls.c (renamed from librabbitmq/amqp-gnutls.c)2
-rw-r--r--librabbitmq/amqp_openssl.c (renamed from librabbitmq/amqp-openssl.c)2
-rw-r--r--librabbitmq/amqp_polarssl.c (renamed from librabbitmq/amqp-polarssl.c)2
-rw-r--r--librabbitmq/amqp_private.h2
-rw-r--r--librabbitmq/amqp_socket.h (renamed from librabbitmq/amqp-socket.h)0
-rw-r--r--librabbitmq/amqp_ssl_socket.h (renamed from librabbitmq/amqp-ssl-socket.h)4
-rw-r--r--librabbitmq/amqp_tcp_socket.c (renamed from librabbitmq/amqp-tcp-socket.c)2
-rw-r--r--librabbitmq/amqp_tcp_socket.h (renamed from librabbitmq/amqp-tcp-socket.h)0
-rw-r--r--tools/common.c4
30 files changed, 42 insertions, 38 deletions
diff --git a/Makefile.am b/Makefile.am
index 92c35b9..3201f7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,7 +13,7 @@ lib_LTLIBRARIES = librabbitmq/librabbitmq.la
librabbitmq_librabbitmq_la_SOURCES = \
librabbitmq/amqp-socket.h \
- librabbitmq/amqp-tcp-socket.c \
+ librabbitmq/amqp_tcp_socket.c \
librabbitmq/amqp_api.c \
librabbitmq/amqp_connection.c \
librabbitmq/amqp_mem.c \
@@ -29,19 +29,19 @@ librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp_framing.c
endif
if SSL_CYASSL
-librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp-cyassl.c
+librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp_cyassl.c
endif
if SSL_GNUTLS
-librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp-gnutls.c
+librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp_gnutls.c
endif
if SSL_OPENSSL
-librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp-openssl.c
+librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp_openssl.c
endif
if SSL_POLARSSL
-librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp-polarssl.c
+librabbitmq_librabbitmq_la_SOURCES += librabbitmq/amqp_polarssl.c
endif
librabbitmq_librabbitmq_la_CFLAGS = \
@@ -71,10 +71,10 @@ endif
include_HEADERS = \
$(top_srcdir)/librabbitmq/amqp.h
- $(top_builddir)/librabbitmq/amqp-tcp-socket.h \
+ $(top_builddir)/librabbitmq/amqp_tcp_socket.h
if SSL
-include_HEADERS += librabbitmq/amqp-ssl-socket.h
+include_HEADERS += librabbitmq/amqp_ssl_socket.h
endif
if REGENERATE_AMQP_FRAMING
diff --git a/examples/amqp_bind.c b/examples/amqp_bind.c
index 1bc82f9..765e746 100644
--- a/examples/amqp_bind.c
+++ b/examples/amqp_bind.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_consumer.c b/examples/amqp_consumer.c
index ea97428..72bf654 100644
--- a/examples/amqp_consumer.c
+++ b/examples/amqp_consumer.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_exchange_declare.c b/examples/amqp_exchange_declare.c
index 091ce30..55860e5 100644
--- a/examples/amqp_exchange_declare.c
+++ b/examples/amqp_exchange_declare.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_listen.c b/examples/amqp_listen.c
index 3ad9fdd..9385c17 100644
--- a/examples/amqp_listen.c
+++ b/examples/amqp_listen.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_listenq.c b/examples/amqp_listenq.c
index 08f3d2a..54c1189 100644
--- a/examples/amqp_listenq.c
+++ b/examples/amqp_listenq.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_producer.c b/examples/amqp_producer.c
index aa86e63..efa1a20 100644
--- a/examples/amqp_producer.c
+++ b/examples/amqp_producer.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_rpc_sendstring_client.c b/examples/amqp_rpc_sendstring_client.c
index 0b187f6..6688195 100644
--- a/examples/amqp_rpc_sendstring_client.c
+++ b/examples/amqp_rpc_sendstring_client.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_sendstring.c b/examples/amqp_sendstring.c
index 0e624f9..0b64024 100644
--- a/examples/amqp_sendstring.c
+++ b/examples/amqp_sendstring.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqp_unbind.c b/examples/amqp_unbind.c
index cc42d1a..7948d0b 100644
--- a/examples/amqp_unbind.c
+++ b/examples/amqp_unbind.c
@@ -39,7 +39,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <amqp.h>
#include <amqp_framing.h>
diff --git a/examples/amqps_bind.c b/examples/amqps_bind.c
index 050be73..1a9328d 100644
--- a/examples/amqps_bind.c
+++ b/examples/amqps_bind.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include "utils.h"
diff --git a/examples/amqps_consumer.c b/examples/amqps_consumer.c
index cccbe33..5832421 100644
--- a/examples/amqps_consumer.c
+++ b/examples/amqps_consumer.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include <assert.h>
diff --git a/examples/amqps_exchange_declare.c b/examples/amqps_exchange_declare.c
index bcf30b1..ed46348 100644
--- a/examples/amqps_exchange_declare.c
+++ b/examples/amqps_exchange_declare.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include "utils.h"
diff --git a/examples/amqps_listen.c b/examples/amqps_listen.c
index 25f8371..8d99066 100644
--- a/examples/amqps_listen.c
+++ b/examples/amqps_listen.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include <assert.h>
diff --git a/examples/amqps_listenq.c b/examples/amqps_listenq.c
index 2bb1760..74aa813 100644
--- a/examples/amqps_listenq.c
+++ b/examples/amqps_listenq.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include <assert.h>
diff --git a/examples/amqps_producer.c b/examples/amqps_producer.c
index 866f8f8..9cf32ab 100644
--- a/examples/amqps_producer.c
+++ b/examples/amqps_producer.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include "utils.h"
diff --git a/examples/amqps_sendstring.c b/examples/amqps_sendstring.c
index c1f10df..d3a647e 100644
--- a/examples/amqps_sendstring.c
+++ b/examples/amqps_sendstring.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include "utils.h"
diff --git a/examples/amqps_unbind.c b/examples/amqps_unbind.c
index 58a6730..53c6088 100644
--- a/examples/amqps_unbind.c
+++ b/examples/amqps_unbind.c
@@ -35,7 +35,7 @@
#include <string.h>
#include <stdint.h>
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#include <amqp_framing.h>
#include "utils.h"
diff --git a/librabbitmq/CMakeLists.txt b/librabbitmq/CMakeLists.txt
index 3a42a19..52e2682 100644
--- a/librabbitmq/CMakeLists.txt
+++ b/librabbitmq/CMakeLists.txt
@@ -80,23 +80,23 @@ if (ENABLE_SSL_SUPPORT)
add_definitions(-DWITH_SSL=1)
if (SSL_ENGINE STREQUAL "OpenSSL")
- set(AMQP_SSL_SRCS amqp-ssl-socket.h amqp-openssl.c)
+ set(AMQP_SSL_SRCS amqp_ssl_socket.h amqp_openssl.c)
include_directories(${OPENSSL_INCLUDE_DIR})
set(AMQP_SSL_LIBS ${OPENSSL_LIBRARIES})
elseif (SSL_ENGINE STREQUAL "cyaSSL")
- set(AMQP_SSL_SRCS amqp-ssl-socket.h amqp-cyassl.c)
+ set(AMQP_SSL_SRCS amqp_ssl_socket.h amqp_cyassl.c)
include_directories(${CYASSL_INCLUDE_DIR})
set(AMQP_SSL_LIBS ${CYASSL_LIBRARIES})
elseif (SSL_ENGINE STREQUAL "GnuTLS")
- set(AMQP_SSL_SRCS amqp-ssl-socket.h amqp-gnutls.c)
+ set(AMQP_SSL_SRCS amqp_ssl_socket.h amqp_gnutls.c)
include_directories(${GNUTLS_INCLUDE_DIR})
add_definitions(${GNUTLS_DEFINITIONS})
set(AMQP_SSL_LIBS ${GNUTLS_LIBRARIES})
elseif (SSL_ENGINE STREQUAL "PolarSSL")
- set(AMQP_SSL_SRCS amqp-ssl-socket.h amqp-polarssl.c)
+ set(AMQP_SSL_SRCS amqp_ssl_socket.h amqp_polarssl.c)
include_directories(${POLARSSL_INCLUDE_DIR})
set(AMQP_SSL_LIBS ${POLARSSL_LIBRARIES})
@@ -118,7 +118,7 @@ set(RABBITMQ_SOURCES
${AMQP_FRAMING_H_PATH}
${AMQP_FRAMING_C_PATH}
amqp_api.c amqp.h amqp_connection.c amqp_mem.c amqp_private.h amqp_socket.c
- amqp_table.c amqp_url.c amqp-socket.h amqp-tcp-socket.c amqp-tcp-socket.h
+ amqp_table.c amqp_url.c amqp_socket.h amqp_tcp_socket.c amqp_tcp_socket.h
${SOCKET_IMPL}/socket.h ${SOCKET_IMPL}/socket.c
${AMQP_SSL_SRCS}
)
diff --git a/librabbitmq/amqp_connection.c b/librabbitmq/amqp_connection.c
index 4666100..f468f16 100644
--- a/librabbitmq/amqp_connection.c
+++ b/librabbitmq/amqp_connection.c
@@ -38,7 +38,7 @@
#include "config.h"
#endif
-#include "amqp-tcp-socket.h"
+#include "amqp_tcp_socket.h"
#include "amqp_private.h"
#include <assert.h>
#include <errno.h>
diff --git a/librabbitmq/amqp-cyassl.c b/librabbitmq/amqp_cyassl.c
index f3ee909..1daf7a9 100644
--- a/librabbitmq/amqp-cyassl.c
+++ b/librabbitmq/amqp_cyassl.c
@@ -24,7 +24,7 @@
#include "config.h"
#endif
-#include "amqp-ssl-socket.h"
+#include "amqp_ssl_socket.h"
#include "amqp_private.h"
#include <cyassl/ssl.h>
#include <stdlib.h>
diff --git a/librabbitmq/amqp-gnutls.c b/librabbitmq/amqp_gnutls.c
index 66b3def..93273d7 100644
--- a/librabbitmq/amqp-gnutls.c
+++ b/librabbitmq/amqp_gnutls.c
@@ -24,7 +24,7 @@
#include "config.h"
#endif
-#include "amqp-ssl-socket.h"
+#include "amqp_ssl_socket.h"
#include "amqp_private.h"
#include <gnutls/gnutls.h>
#include <gnutls/x509.h>
diff --git a/librabbitmq/amqp-openssl.c b/librabbitmq/amqp_openssl.c
index 04be202..c3451ae 100644
--- a/librabbitmq/amqp-openssl.c
+++ b/librabbitmq/amqp_openssl.c
@@ -24,7 +24,7 @@
#include "config.h"
#endif
-#include "amqp-ssl-socket.h"
+#include "amqp_ssl_socket.h"
#include "amqp_private.h"
#include "threads.h"
#include <ctype.h>
diff --git a/librabbitmq/amqp-polarssl.c b/librabbitmq/amqp_polarssl.c
index 125918f..1c7c9f3 100644
--- a/librabbitmq/amqp-polarssl.c
+++ b/librabbitmq/amqp_polarssl.c
@@ -24,7 +24,7 @@
#include "config.h"
#endif
-#include "amqp-ssl-socket.h"
+#include "amqp_ssl_socket.h"
#include "amqp_private.h"
#include <polarssl/ctr_drbg.h>
#include <polarssl/entropy.h>
diff --git a/librabbitmq/amqp_private.h b/librabbitmq/amqp_private.h
index d32f664..7f22ce8 100644
--- a/librabbitmq/amqp_private.h
+++ b/librabbitmq/amqp_private.h
@@ -92,7 +92,7 @@
char *
amqp_os_error_string(int err);
-#include "amqp-socket.h"
+#include "amqp_socket.h"
/*
* Connection states: XXX FIX THIS
diff --git a/librabbitmq/amqp-socket.h b/librabbitmq/amqp_socket.h
index a40d13e..a40d13e 100644
--- a/librabbitmq/amqp-socket.h
+++ b/librabbitmq/amqp_socket.h
diff --git a/librabbitmq/amqp-ssl-socket.h b/librabbitmq/amqp_ssl_socket.h
index 87bce35..706d537 100644
--- a/librabbitmq/amqp-ssl-socket.h
+++ b/librabbitmq/amqp_ssl_socket.h
@@ -30,6 +30,8 @@
#include <amqp.h>
+AMQP_BEGIN_DECLS
+
/**
* Create a new SSL/TLS socket object.
*
@@ -131,4 +133,6 @@ void
AMQP_CALL
amqp_set_initialize_ssl_library(amqp_boolean_t do_initialize);
+AMQP_END_DECLS
+
#endif /* AMQP_SSL_H */
diff --git a/librabbitmq/amqp-tcp-socket.c b/librabbitmq/amqp_tcp_socket.c
index d6e6fdb..84d8554 100644
--- a/librabbitmq/amqp-tcp-socket.c
+++ b/librabbitmq/amqp_tcp_socket.c
@@ -25,7 +25,7 @@
#endif
#include "amqp_private.h"
-#include "amqp-tcp-socket.h"
+#include "amqp_tcp_socket.h"
#include <stdio.h>
#include <stdlib.h>
diff --git a/librabbitmq/amqp-tcp-socket.h b/librabbitmq/amqp_tcp_socket.h
index 6e0afa0..6e0afa0 100644
--- a/librabbitmq/amqp-tcp-socket.h
+++ b/librabbitmq/amqp_tcp_socket.h
diff --git a/tools/common.c b/tools/common.c
index abfba4b..c1844ae 100644
--- a/tools/common.c
+++ b/tools/common.c
@@ -40,9 +40,9 @@
#include "common.h"
#ifdef WITH_SSL
-#include <amqp-ssl-socket.h>
+#include <amqp_ssl_socket.h>
#endif
-#include <amqp-tcp-socket.h>
+#include <amqp_tcp_socket.h>
#include <errno.h>
#include <fcntl.h>
#include <stdarg.h>