summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2023-02-06 00:22:27 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2023-02-05 19:31:11 -0500
commit974d71adceae6d742ae20a4c880d99c131f1460a (patch)
treeeedc593f88ff6af6af73cfcaffe5f351f7697eef
parent35c4ef1e11aac420c44bad0523a71898c672c82a (diff)
downloadrabbitmq-c-974d71adceae6d742ae20a4c880d99c131f1460a.tar.gz
Preparation for v0.13.0 releasev0.13.0
Signed-off-by: GitHub <noreply@github.com>
-rw-r--r--CMakeLists.txt2
-rw-r--r--ChangeLog.md12
-rw-r--r--include/rabbitmq-c/amqp.h2
3 files changed, 14 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0a0dc4..a93ade7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
# 4. If any interfaces have been removed since the last public release, then set age to 0.
set(RMQ_SOVERSION_CURRENT 9)
-set(RMQ_SOVERSION_REVISION 3)
+set(RMQ_SOVERSION_REVISION 4)
set(RMQ_SOVERSION_AGE 5)
include(VersionFunctions)
diff --git a/ChangeLog.md b/ChangeLog.md
index ee180b2..d23071a 100644
--- a/ChangeLog.md
+++ b/ChangeLog.md
@@ -1,4 +1,16 @@
# Change Log
+## v0.13.0 - 2023-02-05
+## Fixed
+- Fixed missing option to not install static library (#665)
+- Missing pkgconfig version in v0.12.0 output (#755, #751)
+- Correct return value from amqp_ssl_socket_set_key_buffer (#723)
+
+## Changed
+- Remove OpenSSL code no longer needed when used with OpenSSL >= 1.1.0. (Fixed: #715, #737)
+
+## Added
+- Integration with OSS-Fuzz (#736)
+
## v0.12.0 - 2023-01-31
## Changed
- rabbitmq-c now compiles as C99
diff --git a/include/rabbitmq-c/amqp.h b/include/rabbitmq-c/amqp.h
index beaa343..69d7366 100644
--- a/include/rabbitmq-c/amqp.h
+++ b/include/rabbitmq-c/amqp.h
@@ -120,7 +120,7 @@ AMQP_BEGIN_DECLS
#define AMQP_VERSION_MAJOR 0
#define AMQP_VERSION_MINOR 13
#define AMQP_VERSION_PATCH 0
-#define AMQP_VERSION_IS_RELEASE 0
+#define AMQP_VERSION_IS_RELEASE 1
/**
* \def AMQP_VERSION_CODE