summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2023-05-01 22:24:09 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2023-05-01 15:32:52 -0700
commitd48f5a4958a9fa1d0c8345f94def2c870424511f (patch)
tree68c19d6e0de291598190d9330860996a5daa4244
parenta4a35414b1072015cf278f3059d2be7706229d0c (diff)
downloadrabbitmq-c-d48f5a4958a9fa1d0c8345f94def2c870424511f.tar.gz
cmake: bump minimum required version to 3.22
This is the version that is installed on Ubuntu 22.04-LTS, and what is possible to regularly test with the current infrastructure. 3.19+ is needed to allow for use of CMakePresets.json. Signed-off-by: GitHub <noreply@github.com>
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d8c24d..61a26ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
# Copyright 2007 - 2021, Alan Antonuk and the rabbitmq-c contributors.
# SPDX-License-Identifier: mit
-cmake_minimum_required(VERSION 3.17...3.26)
+cmake_minimum_required(VERSION 3.22...3.26)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)