summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Lepasteur <simon.lepasteur@swissdotnet.ch>2020-03-11 15:13:29 +0100
committerAlan Antonuk <alan.antonuk@gmail.com>2020-03-12 00:20:38 -0700
commit26ecf6d3012be81f5dfb8a2d822c722e916a86cb (patch)
treecf9caf54a7c53f23539549b4b2f9ed3db00099c6 /CMakeLists.txt
parentfffeb013df0d7eac7dd22eef5f6d55fe1f43335c (diff)
downloadrabbitmq-c-26ecf6d3012be81f5dfb8a2d822c722e916a86cb.tar.gz
Add option to run system tests (disabled by default).
System tests require a RabbitMQ or other AMQP server to be running on `localhost` at TCP port number 5672 and therefore fails if no such server is running on the build machine. This is surprising for everyone running the standard `make test` to ensure the library is built correctly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f620ddc..a39645f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -266,6 +266,7 @@ option(BUILD_TOOLS "Build Tools (requires POPT Library)" ${POPT_FOUND})
option(BUILD_TOOLS_DOCS "Build man pages for Tools (requires xmlto)" ${DO_DOCS})
option(BUILD_TESTS "Build tests (run tests with make test)" ON)
option(BUILD_API_DOCS "Build Doxygen API docs" ${DOXYGEN_FOUND})
+option(RUN_SYSTEM_TESTS "Run system tests (i.e. tests requiring an accessible RabbitMQ server instance on localhost)" OFF)
if (NOT BUILD_SHARED_LIBS AND NOT BUILD_STATIC_LIBS)
message(FATAL_ERROR "One or both of BUILD_SHARED_LIBS or BUILD_STATIC_LIBS must be set to ON to build")