summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-06 07:20:36 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-06 00:29:38 -0700
commit5d1fd824227f8eb20b1ac2eb63d6533d7479556a (patch)
tree9734516781323016d7b2568268bdaa804a7666c8 /CMakeLists.txt
parentc8c117097934c9d2ecab30ce70efba98f0e267f8 (diff)
downloadrabbitmq-c-5d1fd824227f8eb20b1ac2eb63d6533d7479556a.tar.gz
cmake: use GenerateExportHeader for AMQP_EXPORT
Use cmake's GenerateExportHeader to define AMQP_EXPORT & AMQP_DEPRECATED over the one in amqp.h. This is likely to be more correct over time. Note this requires bumping the minimum required version from v3.10 to v3.12 to pick up support in CMake for C libraries. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b330f4..428b1e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,4 @@
-cmake_minimum_required(VERSION 3.10...3.18)
-
-if(${CMAKE_VERSION} VERSION_LESS 3.12)
- cmake_policy(VERSION ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION})
-endif()
+cmake_minimum_required(VERSION 3.12...3.18)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)