summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-07-27 23:41:10 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-07-27 17:40:14 -0700
commit7f1a431be527b3ca660b743f7333e147b3166ec5 (patch)
tree2f5a01f23ce0ca3b612a6cb69ef5e3c321993885 /CMakeLists.txt
parentfd51cf8fdc41c3d4f4a1e8cc7ea9aea5bfbe0a0d (diff)
downloadrabbitmq-c-7f1a431be527b3ca660b743f7333e147b3166ec5.tar.gz
Update copyright & license header to use SPDX id
This makes license detection machine-readable, and makes source files more concise and easier to read and understand. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b091e3..fd70faa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright 2007 - 2021, Alan Antonuk and the rabbitmq-c contributors.
+# SPDX-License-Identifier: mit
+
cmake_minimum_required(VERSION 3.12...3.18)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)