summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-05-21 05:10:07 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-05-20 22:34:44 -0700
commit86743900aa1b3bb5acd1da84bc0979b83b696ad4 (patch)
treeab74f4772753993692daece33af10f5be18c6c30 /CMakeLists.txt
parent53a8834b9845dae5467c62a53cf19fddb5be1780 (diff)
downloadrabbitmq-c-86743900aa1b3bb5acd1da84bc0979b83b696ad4.tar.gz
lib: compile rabbitmq-c as C99
It is believed that enough maintained platforms (Linux, MacOS, Win32) have a compiler that supports a compiler that can compile in C99. This also removes the need to maintain a number of workarounds, as well as awkward coding patterns. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c9a0a8..f236451 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,7 @@ project(rabbitmq-c
DESCRIPTION "C RabbitMQ AMQP client library"
LANGUAGES C)
-set(CMAKE_C_STANDARD 90)
+set(CMAKE_C_STANDARD 99)
set(CMAKE_C_STANDARD_REQUIRED ON)
set(CMAKE_C_EXTENSIONS ON)