summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <aega@med.umich.edu>2011-11-01 18:03:53 -0400
committerAlan Antonuk <aega@med.umich.edu>2011-11-01 18:03:53 -0400
commit89db105a5a7596bfdf00824911a5cba97d0e6668 (patch)
treea190cb2eaeccbd4f071a9e5b027a1a3a6b600fba /CMakeLists.txt
parent7715ad8f53930d3e5956d219cfc0233eea59a2b5 (diff)
downloadrabbitmq-c-89db105a5a7596bfdf00824911a5cba97d0e6668.tar.gz
Adding POPT CMake lib finder.
Utilities in the tools/ directory will now be built if the popt library is found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 272816a..c333d0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,14 @@ endif (FETCH_CODEGEN_FROM_GIT)
mark_as_advanced(AMQP_CODEGEN_DIR)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
+
+find_package(POPT)
add_subdirectory(librabbitmq)
add_subdirectory(examples)
+if (POPT_FOUND)
+ add_subdirectory(tools)
+endif (POPT_FOUND)
+