summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-12 05:10:01 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-11 22:37:57 -0700
commitb453ad06e549c02af858e6f0672e8b9c74dc6554 (patch)
tree1ad921744a4df2269917e7c58e022a4d4134456b /CMakeLists.txt
parenta3299298ad8b75ffa294529e217882f2755821f6 (diff)
downloadrabbitmq-c-b453ad06e549c02af858e6f0672e8b9c74dc6554.tar.gz
cmake: specify COMPONENT on install commands
To help package managers cmake install commands now specify a COMPONENT. Components include: - rabbitmq-c-runtime: libraries necessary for running programs linked against rabbitmq-c. - rabbitmq-c-development: static libraries, headers necessary for building programs against rabbitmq-c - rabbitmq-c-tools: CLI tools for interacting with RabbitMQ broker - rabbitmq-c-tool-docs: man pages for CLI tools. This also updates the tool install directory to use GnuInstallDirs- compatible location Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9752984..4658638 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -332,11 +332,13 @@ export(TARGETS ${INSTALL_TARGETS}
install(FILES ${project_config} ${version_config}
DESTINATION ${RMQ_CMAKE_DIR}
+ COMPONENT rabbitmq-c-development
)
install(EXPORT ${targets_export_name}
DESTINATION ${RMQ_CMAKE_DIR}
NAMESPACE rabbitmq::
+ COMPONENT rabbitmq-c-development
)
install(FILES