summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2023-04-30 15:30:13 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2023-04-30 08:49:11 -0700
commitd2b75b093d56f5c435f5d8c6fd4ff8eb550b2245 (patch)
tree409876805a93f519ed1b8a9391025511b83bef1f /CMakeLists.txt
parent8889ef336d7af66fb4a0e3398db4c3701c33d3e1 (diff)
downloadrabbitmq-c-d2b75b093d56f5c435f5d8c6fd4ff8eb550b2245.tar.gz
Correct library versions on Mach-O platforms
Set the compatibility and current version strings on Mach-O (Apple) platforms. The compatibility version remains the same as the SOVERSION, the current version is SOVERSION.AGE.REVISION, which matches the previous libtool semantics for this. Fixes #758 Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a93ade7..7d8c24d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
# Copyright 2007 - 2021, Alan Antonuk and the rabbitmq-c contributors.
# SPDX-License-Identifier: mit
-cmake_minimum_required(VERSION 3.12...3.18)
+cmake_minimum_required(VERSION 3.17...3.26)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)