summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2023-05-03 02:52:51 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2023-05-02 20:06:20 -0700
commite2774a9abf0c52ec5a15b4d5684bfe3e94a7f12a (patch)
tree57faaa53065bb3565224905da3054715d38b291d /CMakeLists.txt
parentfe91b5cf421d8965451792104cccb1b526abacde (diff)
downloadrabbitmq-c-e2774a9abf0c52ec5a15b4d5684bfe3e94a7f12a.tar.gz
Make cmake package-config find OpenSSL when used
This makes the rabbitmq-c-config.cmake package config correctly find the OpenSSL library dependency when required. Fixes: #725 Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b476f1..9b4921e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -113,7 +113,8 @@ endif()
option(ENABLE_SSL_SUPPORT "Enable SSL support" ON)
if (ENABLE_SSL_SUPPORT)
- find_package(OpenSSL 1.1.1 REQUIRED)
+ set(RMQ_OPENSSL_MIN_VERSION 1.1.1)
+ find_package(OpenSSL "${RMQ_OPENSSL_MIN_VERSION}" REQUIRED)
cmake_push_check_state()
set(THREADS_PREFER_PTHREAD_FLAG ON)