summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-01 06:04:33 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-03-31 23:26:41 -0700
commite2ee767868531e837391c91caf0fefe2a4f3a993 (patch)
treef87c57546e9fa6666e5d58f4bc6b11150d36d486 /CMakeLists.txt
parentb074b92e76630ca6b4bd187dcfdfeb327322215b (diff)
downloadrabbitmq-c-e2ee767868531e837391c91caf0fefe2a4f3a993.tar.gz
cmake: remove code that manipulates CMAKE_C_FLAGS
Manipulating CMAKE_C_FLAGS directly within the CMakeLists.txt is generally frowned upon, and error-prone as compilers evolve. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4228fa..bae759d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -132,19 +132,6 @@ if (ENABLE_SSL_SUPPORT)
cmake_pop_check_state()
endif()
-if (MSVC)
- set(CMAKE_C_FLAGS "/W4 /nologo ${CMAKE_C_FLAGS}")
-elseif (CMAKE_C_COMPILER_ID MATCHES ".*Clang")
- set(CMAKE_C_FLAGS "-Wall -Wextra -Wstrict-prototypes -Wno-unused-function -fno-common -fvisibility=hidden ${CMAKE_C_FLAGS}")
-elseif (CMAKE_COMPILER_IS_GNUCC)
- set(RMQ_C_FLAGS "-Wall -Wextra -Wstrict-prototypes -Wno-unused-function -fno-common")
- execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
- if (GCC_VERSION VERSION_GREATER 4.0 OR GCC_VERSION VERSION_EQUAL 4.0)
- set(RMQ_C_FLAGS "${RMQ_C_FLAGS} -fvisibility=hidden")
- endif()
- set(CMAKE_C_FLAGS "${RMQ_C_FLAGS} ${CMAKE_C_FLAGS}")
-endif ()
-
option(REGENERATE_AMQP_FRAMING "Regenerate amqp_framing.h/amqp_framing.c sources (for developer use)" OFF)
mark_as_advanced(REGENERATE_AMQP_FRAMING)