summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Wragg <david@rabbitmq.com>2010-10-21 17:49:04 +0100
committerDavid Wragg <david@rabbitmq.com>2010-10-21 17:49:04 +0100
commitba49cb334a0a9ff96956c22ea6eab8920123c6a2 (patch)
tree374f3df9e93d0958f4a94c52ef189a8a56a3e138 /configure.ac
parent1096c1dbdb961bab603f504b9aaee864f6192c97 (diff)
downloadrabbitmq-c-ba49cb334a0a9ff96956c22ea6eab8920123c6a2.tar.gz
Use the msinttypes header when building with the Microsoft compiler
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c7672a8..4077362 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,13 +97,22 @@ AC_SUBST(AMQP_CODEGEN_DIR)
AC_SUBST(AMQP_SPEC_JSON_PATH)
AC_SUBST(PYTHON)
-dnl Decide which extra win32 libs we need
+dnl Decide which extra win32 libs we need, and handle other special
+dnl cases when building with the Microsoft compiler
EXTRA_LIBS=
+USE_MISINTTYPES=
AS_IF([test "x$windows" = xyes],
- [AS_IF([test "x$GCC" = xyes],
- [EXTRA_LIBS="-lws2_32 $EXTRA_LIBS"],
- [EXTRA_LIBS="ws2_32.lib $EXTRA_LIBS"])])
+ [
+ AS_IF([test "x$GCC" = xyes],
+ [EXTRA_LIBS="-lws2_32 $EXTRA_LIBS"],
+ [
+ EXTRA_LIBS="ws2_32.lib $EXTRA_LIBS"
+ USE_MSINTTYPES=yes
+ ])
+ ])
+
AC_SUBST(EXTRA_LIBS)
+AM_CONDITIONAL(USE_MSINTTYPES, test "x$USE_MSINTTYPES" != "x")
dnl Check for libpopt, which we need to build the tools
AC_ARG_WITH([popt],