summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorTony Garnock-Jones <tonyg@kcbbs.gen.nz>2009-04-25 19:41:56 +0100
committerTony Garnock-Jones <tonyg@kcbbs.gen.nz>2009-04-25 19:41:56 +0100
commit67970c9c56ebd49b57e61d50255b04fa1ac7d27d (patch)
treeec02d63a0a7b8f31b7a0c0426eeaab25f5884e1f /examples
parent8bf174bc0a3d682ff9c8c11435008f1adf3c288f (diff)
downloadrabbitmq-c-67970c9c56ebd49b57e61d50255b04fa1ac7d27d.tar.gz
Codegen, codec
Diffstat (limited to 'examples')
-rw-r--r--examples/Makefile.am4
-rw-r--r--examples/amqp_sendstring.c12
2 files changed, 16 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000..226294f
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,4 @@
+bin_PROGRAMS = amqp_sendstring
+
+AM_CFLAGS = -I../librabbitmq
+AM_LDFLAGS = ../librabbitmq/librabbitmq.la
diff --git a/examples/amqp_sendstring.c b/examples/amqp_sendstring.c
new file mode 100644
index 0000000..9258f7f
--- /dev/null
+++ b/examples/amqp_sendstring.c
@@ -0,0 +1,12 @@
+#include <stdlib.h>
+#include <stdio.h>
+#include <string.h>
+
+#include <stdint.h>
+#include "amqp.h"
+
+int main(int argc, char const * const *argv) {
+ amqp_connection_state_t conn = amqp_new_connection();
+ amqp_destroy_connection(conn);
+ return 0;
+}