summaryrefslogtreecommitdiff
path: root/librabbitmq
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-02 06:28:05 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-01 23:40:05 -0700
commit188d1be3e3498c5843b8f9fc439b828c64af57fd (patch)
tree7b9699e5a71248c9a06453220331b704ef5d2bdb /librabbitmq
parentd5bbafae56ddcc3fcbef49b35271b7abab8c2621 (diff)
downloadrabbitmq-c-188d1be3e3498c5843b8f9fc439b828c64af57fd.tar.gz
cmake: use modern version of project() command
This also gets rid of a non-top-level project command that probably shouldn't be used. Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'librabbitmq')
-rw-r--r--librabbitmq/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/librabbitmq/CMakeLists.txt b/librabbitmq/CMakeLists.txt
index d8dcd26..ba9edf4 100644
--- a/librabbitmq/CMakeLists.txt
+++ b/librabbitmq/CMakeLists.txt
@@ -1,5 +1,3 @@
-project(librabbitmq "C")
-
if (REGENERATE_AMQP_FRAMING)
set(AMQP_CODEGEN_PY "${CMAKE_CURRENT_BINARY_DIR}/amqp_codegen.py")
set(CODEGEN_PY "${CMAKE_CURRENT_BINARY_DIR}/codegen.py")