summaryrefslogtreecommitdiff
path: root/librabbitmq
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2021-04-20 05:03:16 +0000
committerAlan Antonuk <alan.antonuk@gmail.com>2021-04-20 20:47:47 -0700
commitabf958c0679584769ce17e6261710eae83980fce (patch)
treeec93492ccd9b338c387f6cfe63e7611d2ea8cc69 /librabbitmq
parent5487ac0ce50e36d01cfbb14f33eeac91ae5e7f15 (diff)
downloadrabbitmq-c-abf958c0679584769ce17e6261710eae83980fce.tar.gz
lib: Fix minor issues with codegen
Signed-off-by: GitHub <noreply@github.com>
Diffstat (limited to 'librabbitmq')
-rw-r--r--librabbitmq/CMakeLists.txt1
-rw-r--r--librabbitmq/codegen.py1
2 files changed, 2 insertions, 0 deletions
diff --git a/librabbitmq/CMakeLists.txt b/librabbitmq/CMakeLists.txt
index b3100bd..ee9555c 100644
--- a/librabbitmq/CMakeLists.txt
+++ b/librabbitmq/CMakeLists.txt
@@ -77,6 +77,7 @@ set(PUBLIC_INCLUDE_DIRS
set(PRIVATE_INCLUDE_DIRS
${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
${SSL_INCLUDE_DIRS}
)
diff --git a/librabbitmq/codegen.py b/librabbitmq/codegen.py
index a9e4e07..3e86edf 100644
--- a/librabbitmq/codegen.py
+++ b/librabbitmq/codegen.py
@@ -604,6 +604,7 @@ def genHrl(spec):
#define RABBITMQ_C_FRAMING_H
#include <rabbitmq-c/amqp.h>
+#include <rabbitmq-c/export.h>
AMQP_BEGIN_DECLS
"""