summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorSimon Lepasteur <simon.lepasteur@swissdotnet.ch>2020-03-11 15:13:29 +0100
committerAlan Antonuk <alan.antonuk@gmail.com>2020-03-12 00:20:38 -0700
commit26ecf6d3012be81f5dfb8a2d822c722e916a86cb (patch)
treecf9caf54a7c53f23539549b4b2f9ed3db00099c6 /tests
parentfffeb013df0d7eac7dd22eef5f6d55fe1f43335c (diff)
downloadrabbitmq-c-26ecf6d3012be81f5dfb8a2d822c722e916a86cb.tar.gz
Add option to run system tests (disabled by default).
System tests require a RabbitMQ or other AMQP server to be running on `localhost` at TCP port number 5672 and therefore fails if no such server is running on the build machine. This is surprising for everyone running the standard `make test` to ensure the library is built correctly.
Diffstat (limited to 'tests')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index cf042b0..320a73d 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -33,9 +33,11 @@ add_executable(test_basic
test_basic.c)
target_link_libraries(test_basic rabbitmq-static)
-if (NOT APPLE)
- add_test(basic test_basic)
-endif()
+if (RUN_SYSTEM_TESTS)
+ if (NOT APPLE)
+ add_test(basic test_basic)
+ endif()
+endif(RUN_SYSTEM_TESTS)
add_executable(test_sasl_mechanism test_sasl_mechanism.c)
target_link_libraries(test_sasl_mechanism rabbitmq-static)