summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorAlan Antonuk <alan.antonuk@gmail.com>2015-04-05 22:52:07 -0700
committerAlan Antonuk <alan.antonuk@gmail.com>2015-04-05 23:37:23 -0700
commita5f7ffb3b6e04304930a22d1a86f89c9fbf713d9 (patch)
tree71da7e91d0b93ba3e6c2c5c7e11f158d4fbc0bc4 /tests
parent133dffeec9b991c18b7c5e38cba112c8a9b6ed34 (diff)
downloadrabbitmq-c-a5f7ffb3b6e04304930a22d1a86f89c9fbf713d9.tar.gz
Make tests only link against static rabbitmq
This gets around issues with symbol visibility issues while testing functions that are not declared to be visibile outside the library.
Diffstat (limited to 'tests')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index c8d96d7..fca99fc 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -11,11 +11,11 @@ endif (MSVC)
add_definitions(-DHAVE_CONFIG_H)
add_executable(test_parse_url test_parse_url.c)
-target_link_libraries(test_parse_url ${RMQ_LIBRARY_TARGET})
+target_link_libraries(test_parse_url rabbitmq-static)
add_test(parse_url test_parse_url)
add_executable(test_tables test_tables.c)
-target_link_libraries(test_tables ${RMQ_LIBRARY_TARGET})
+target_link_libraries(test_tables rabbitmq-static)
add_test(tables test_tables)
configure_file(test_tables.expected ${CMAKE_CURRENT_BINARY_DIR}/tests/test_tables.expected COPY_ONLY)
@@ -26,5 +26,5 @@ add_test(hostcheck test_hostcheck)
add_executable(test_status_enum
test_status_enum.c)
-target_link_libraries(test_status_enum ${RMQ_LIBRARY_TARGET})
+target_link_libraries(test_status_enum rabbitmq-static)
add_test(status_enum test_status_enum)